aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in4
-rw-r--r--NEWS7
-rw-r--r--fetchmail.man16
-rwxr-xr-xfetchmailconf2
4 files changed, 20 insertions, 9 deletions
diff --git a/Makefile.in b/Makefile.in
index b01f8feb..2a9ad7da 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -144,9 +144,11 @@ $(bindir)/fetchmailconf: fetchmailconf
$(mandir)/fetchmail.$(manext): fetchmail.man
@echo "Installing manual page..."
$(INSTALL_DATA) $(srcdir)/fetchmail.man $@
+ ln -s $(mandir)/fetchmail.$(manext) $(mandir)/fetchmailconf.$(manext)
uninstall:
- rm -f $(bindir)/fetchmail $(bindir)/fetchmailconf $(mandir)/fetchmail.$(manext)
+ rm -f $(bindir)/fetchmail $(bindir)/fetchmailconf
+ rm -f $(mandir)/fetchmail.$(manext) $(mandir)/fetchmailconf.$(manext)
.PHONY: clean realclean distclean mostlyclean
clean:
diff --git a/NEWS b/NEWS
index 4b41a536..c529cb73 100644
--- a/NEWS
+++ b/NEWS
@@ -8,6 +8,7 @@
------------------------------------------------------------------------------
fetchmail-4.4.8 ():
+* Added 0.90 beta version of fetchmailconf.
* Removed fetchall side-effect kluge, now that we knowe how to make TOP work
with qpopper 2.3+.
* Patch by Kok Seng to prevent loss of UID info when a query fails.
@@ -19,19 +20,19 @@ fetchmail-4.4.8 ():
* when makeing sure we have a nonempty host list to forward to, I
added "localhost" for non ETRN protocols. This should relieve the
situation for people, who do neither have a static ip-address
- (hostname) assigned and neither bother to set up a dummy-interface
+ (hostname) assigned and don't bother to set up a dummy-interface
for their hostname. I think this feature was already in fetchmail
in an older version. We lost this, when we changed the code that it
would work with ETRN. My fix here works for both ETRN and non ETRN.
- - fixed reversed dumping of mimedecode option
- in options.c
* changed char buf[...] to *buf + xmalloc to avoid buffer overuns and
possible resulting (and annoying) coredumps
* in parsecmdline(): replaced atoi by xatoi which uses strtol and
better validity checks for input numbers. This fix only works on
ANSI-C systems; old systems still use atoi.
+ - fixed reversed dumping of mimedecode option
-There are 270 people on fetchmail-friends and 214 on fetchmail-announce.
+There are 272 people on fetchmail-friends and 214 on fetchmail-announce.
fetchmail-4.4.7 (Sat May 23 08:26:58 EDT 1998):
* FEATURE FREEZE IS NOW IN EFFECT! No new features until after 4.5.0.
diff --git a/fetchmail.man b/fetchmail.man
index 9ac22b26..d8717508 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -10,6 +10,8 @@ fetchmail \- fetch mail from a POP, IMAP, or ETRN-capable server
.SH SYNOPSIS
\fBfetchmail\fR [\fIoptions\fR] [\fImailserver...\fR]
+.br
+\fBfetchmailconf\fR
.SH DESCRIPTION
.I fetchmail
@@ -43,11 +45,19 @@ as \fIsmail\fR, \fImmdf\fR, or \fIqmail\fR). All the delivery-control
mechanisms (such as \fI.forward\fR files) normally available through
your system MDA and local delivery agents will therefore work.
.PP
+If the program
+.I fetchmailconf
+is available, it will assist you in setting up and editing a
+fetchmailrc configuration. It runs under X and requires that the
+language Python and the Tk toolkit be present on your system.
+
+.SH GENERAL OPERATION
The behavior of
.I fetchmail
is controlled by command-line options and a run control file,
-\fI~/.fetchmailrc\fR, the syntax of which we describe below. Command-line
-options override
+.IR ~/.fetchmailrc\fR ,
+the syntax of which we describe in a later section (this file is what
+the \fIfetchmailconf\fR program edits). Command-line options override
.I ~/.fetchmailrc
declarations.
.PP
@@ -61,8 +71,6 @@ To facilitate the use of
.I fetchmail
In scripts, pipelines, etc., it returns an appropriate exit code upon
termination -- see EXIT CODES below.
-
-.SH OPTIONS
The following options modify the behavior of \fIfetchmail\fR. It is
seldom necessary to specify any of these once you have a
working \fI.fetchmailrc\fR file set up.
diff --git a/fetchmailconf b/fetchmailconf
index f4cd4635..93fd94d1 100755
--- a/fetchmailconf
+++ b/fetchmailconf
@@ -4,7 +4,7 @@
# by Eric S. Raymond, <esr@snark.thyrsus.com>.
# Requires Python with Tkinter, and both posix and posixpath services.
#
-# Version 0.99 beta: Tue May 26 12:00:49 EDT 1998
+# Version 0.90 beta: Tue May 26 12:00:49 EDT 1998
#
# TO DO: Arrange for save and quit buttons to clean up all frames dependent
# on the current ones.