aboutsummaryrefslogtreecommitdiffstats
path: root/trio/configure.in
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2010-02-26 03:09:21 +0100
committerMatthias Andree <matthias.andree@gmx.de>2010-02-26 03:11:47 +0100
commit90ec0bf58bf8cd9e59fd4cab2c1dbfde9b4119e1 (patch)
tree98d5905baa26c2976b57060de5de6665ad2076ba /trio/configure.in
parent64d253be1e67688147246819eeb8e4f8f8e77243 (diff)
downloadfetchmail-90ec0bf58bf8cd9e59fd4cab2c1dbfde9b4119e1.tar.gz
fetchmail-90ec0bf58bf8cd9e59fd4cab2c1dbfde9b4119e1.tar.bz2
fetchmail-90ec0bf58bf8cd9e59fd4cab2c1dbfde9b4119e1.zip
Import new trio version, disabling config.h #include.
Diffstat (limited to 'trio/configure.in')
-rw-r--r--trio/configure.in56
1 files changed, 31 insertions, 25 deletions
diff --git a/trio/configure.in b/trio/configure.in
index 212684d5..f1ed7659 100644
--- a/trio/configure.in
+++ b/trio/configure.in
@@ -2,11 +2,13 @@ dnl
dnl Configuration for trio
dnl
-AC_INIT(triodef.h)
+AC_INIT
+AC_CONFIG_SRCDIR([triodef.h])
+AC_PREREQ(2.55) dnl autoconf 2.55 was released in 2002
AC_PROG_CC
ifdef([AC_PROG_CC_STDC], [AC_PROG_CC_STDC])
-AC_LANG_C
+AC_LANG([C])
AC_PROG_INSTALL
AC_PROG_RANLIB
@@ -17,32 +19,36 @@ dnl
AC_MSG_CHECKING(for IEEE compilation options)
AC_CACHE_VAL(ac_cv_ieee_option, [
-AC_TRY_COMPILE(,[
-#if !(defined(__alpha) && (defined(__DECC) || defined(__DECCXX) || (defined(__osf__) && defined(__LANGUAGE_C__))) && (defined(VMS) || defined(__VMS)))
-# error "Option needed"
-typedef int option_needed[-1];
-#endif
-],ac_cv_ieee_option="/IEEE_MODE=UNDERFLOW_TO_ZERO/FLOAT=IEEE",
-AC_TRY_COMPILE(,[
-#if !(defined(__alpha) && (defined(__DECC) || defined(__DECCXX) || (defined(__osf__) && defined(__LANGUAGE_C__) && !defined(__GNUC__))) && !(defined(VMS) || defined(__VMS)) && !defined(_CFE))
-# error "Option needed"
-typedef int option_needed[-1];
-#endif
-],ac_cv_ieee_option="-ieee",
-AC_TRY_COMPILE(,[
-#if !(defined(__alpha) && (defined(__GNUC__) && (defined(__osf__) || defined(__linux__))))
-# error "Option needed"
-typedef int option_needed[-1];
-#endif
-],ac_cv_ieee_option="-mieee",
-ac_cv_ieee_option="none"
-)
-)
-)
+ AC_COMPILE_IFELSE(AC_LANG_PROGRAM(,[[[
+ #if !(defined(__alpha) && (defined(__DECC) || defined(__DECCXX) || (defined(__osf__) && defined(__LANGUAGE_C__))) && (defined(VMS) || defined(__VMS)))
+ # error "Option needed"
+ typedef int option_needed[-1];
+ #endif
+ ]]]),
+ ac_cv_ieee_option="/IEEE_MODE=UNDERFLOW_TO_ZERO/FLOAT=IEEE",
+ AC_COMPILE_IFELSE(AC_LANG_PROGRAM(,[[[
+ #if !(defined(__alpha) && (defined(__DECC) || defined(__DECCXX) || (defined(__osf__) && defined(__LANGUAGE_C__) && !defined(__GNUC__))) && !(defined(VMS) || defined(__VMS)) && !defined(_CFE))
+ # error "Option needed"
+ typedef int option_needed[-1];
+ #endif
+ ]]]),
+ ac_cv_ieee_option="-ieee",
+ AC_COMPILE_IFELSE(AC_LANG_PROGRAM(,[[[
+ #if !(defined(__alpha) && (defined(__GNUC__) && (defined(__osf__) || defined(__linux__))))
+ # error "Option needed"
+ typedef int option_needed[-1];
+ #endif
+ ]]]),
+ ac_cv_ieee_option="-mieee",
+ ac_cv_ieee_option="none"
+ )
+ )
+ )
])
AC_MSG_RESULT($ac_cv_ieee_option)
if test $ac_cv_ieee_option != none; then
CFLAGS="${CFLAGS} ${ac_cv_ieee_option}"
fi
-AC_OUTPUT(Makefile)
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT