aboutsummaryrefslogtreecommitdiffstats
path: root/trio/configure.in
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2004-11-10 19:04:29 +0000
committerMatthias Andree <matthias.andree@gmx.de>2004-11-10 19:04:29 +0000
commit13c27199231cbc2cc83969ada741b95be1cca4d3 (patch)
tree58c32705247dcf031d6f17d8bc8ef78557d74113 /trio/configure.in
parent486bdc6d20c7e7d8c6eeb3124cf845abefcd7d11 (diff)
downloadfetchmail-13c27199231cbc2cc83969ada741b95be1cca4d3.tar.gz
fetchmail-13c27199231cbc2cc83969ada741b95be1cca4d3.tar.bz2
fetchmail-13c27199231cbc2cc83969ada741b95be1cca4d3.zip
Import Trio 1.10 into fetchmail's trunk.
svn path=/trunk/; revision=3995
Diffstat (limited to 'trio/configure.in')
-rw-r--r--trio/configure.in45
1 files changed, 45 insertions, 0 deletions
diff --git a/trio/configure.in b/trio/configure.in
new file mode 100644
index 00000000..6783959b
--- /dev/null
+++ b/trio/configure.in
@@ -0,0 +1,45 @@
+dnl
+dnl Configuration for trio
+dnl
+
+AC_INIT(triodef.h)
+
+AC_PROG_CC
+ifdef([AC_PROG_CC_STDC], [AC_PROG_CC_STDC])
+AC_LANG_C
+
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+dnl
+dnl Alpha floating-point compiler option.
+dnl
+
+AC_MSG_CHECKING(for IEEE compilation options)
+AC_CACHE_VAL(ac_cv_ieee_option, [
+AC_TRY_COMPILE(,[
+#if !(defined(__alpha) && (defined(__DECC) || defined(__DECCXX) || (defined(__osf__) && defined(__LANGUAGE_C__))) && (defined(VMS) || defined(__VMS)))
+# error "Option needed"
+#endif
+],ac_cv_ieee_option="/IEEE_MODE=UNDERFLOW_TO_ZERO/FLOAT=IEEE",
+AC_TRY_COMPILE(,[
+#if !(defined(__alpha) && (defined(__DECC) || defined(__DECCXX) || (defined(__osf__) && defined(__LANGUAGE_C__))) && !(defined(VMS) || defined(__VMS)) && !defined(_CFE))
+# error "Option needed"
+#endif
+],ac_cv_ieee_option="-ieee",
+AC_TRY_COMPILE(,[
+#if !(defined(__alpha) && (defined(__GNUC__) && (defined(__osf__) || defined(__linux__))))
+# error "Option needed"
+#endif
+],ac_cv_ieee_option="-mieee",
+ac_cv_ieee_option="none"
+)
+)
+)
+])
+AC_MSG_RESULT($ac_cv_ieee_option)
+if test $ac_cv_ieee_option != none; then
+ CFLAGS="${CFLAGS} ${ac_cv_ieee_option}"
+fi
+
+AC_OUTPUT(Makefile)