aboutsummaryrefslogtreecommitdiffstats
path: root/trio/Makefile.in
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2004-11-10 19:04:29 +0000
committerMatthias Andree <matthias.andree@gmx.de>2004-11-10 19:04:29 +0000
commit13c27199231cbc2cc83969ada741b95be1cca4d3 (patch)
tree58c32705247dcf031d6f17d8bc8ef78557d74113 /trio/Makefile.in
parent486bdc6d20c7e7d8c6eeb3124cf845abefcd7d11 (diff)
downloadfetchmail-13c27199231cbc2cc83969ada741b95be1cca4d3.tar.gz
fetchmail-13c27199231cbc2cc83969ada741b95be1cca4d3.tar.bz2
fetchmail-13c27199231cbc2cc83969ada741b95be1cca4d3.zip
Import Trio 1.10 into fetchmail's trunk.
svn path=/trunk/; revision=3995
Diffstat (limited to 'trio/Makefile.in')
-rw-r--r--trio/Makefile.in60
1 files changed, 60 insertions, 0 deletions
diff --git a/trio/Makefile.in b/trio/Makefile.in
new file mode 100644
index 00000000..7be4bcb1
--- /dev/null
+++ b/trio/Makefile.in
@@ -0,0 +1,60 @@
+CC = @CC@
+CFLAGS = @CFLAGS@ -DDEBUG
+OBJS = triostr.o trio.o trionan.o
+TARGETLIB = libtrio.a
+TARGETINCS = trio.h triop.h triodef.h trionan.h triostr.h
+LDFLAGS = -L. -ltrio -lm
+AR = ar
+RANLIB = @RANLIB@
+ERASE = rm -f
+MKDIR = mkdir -p
+GENDOC = doxygen
+
+PURIFY = purify
+PURIFYOPTIONS = -chain-length=16 -first-only=YES
+
+# Installation settings
+INSTALL = @INSTALL@
+INSTALL_DATA = @INSTALL_DATA@
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+includedir = @includedir@
+libdir = @libdir@
+
+all: $(TARGETLIB) $(TARGET) regression
+
+test:
+ ./regression
+
+install: $(TARGETLIB)
+ $(MKDIR) $(libdir)
+ $(MKDIR) $(includedir)
+ $(INSTALL_DATA) $(TARGETLIB) $(libdir)/$(TARGETLIB)
+ for i in $(TARGET_INCS);do \
+ (set -x;$(INSTALL_DATA) $$i $(includedir)); \
+ done
+
+pure: $(TOBJS) $(OBJS)
+ $(PURIFY) $(PURIFYOPTIONS) $(CC) $(CFLAGS) $^ $(LDFLAGS)
+
+regression: regression.o $(TARGETLIB)
+ $(CC) $(CFLAGS) regression.o $(LDFLAGS) -o $@
+
+example: example.o $(TARGETLIB)
+ $(CC) $(CFLAGS) example.o $(LDFLAGS) -o $@
+
+compare: compare.o $(TARGETLIB)
+ $(CC) $(CFLAGS) compare.o $(LDFLAGS) -o $@
+
+userdef: userdef.o $(TARGETLIB)
+ $(CC) $(CFLAGS) userdef.o $(LDFLAGS) -o $@
+
+$(TARGETLIB): $(OBJS)
+ $(AR) ruv $(TARGETLIB) $(OBJS)
+ $(RANLIB) $(TARGETLIB)
+
+doc::
+ $(GENDOC) doc/trio.cfg
+
+clean:
+ $(ERASE) *~ core regression example $(TOBJS) $(OBJS) $(TARGET) $(TARGETLIB) example.o regression.o