aboutsummaryrefslogtreecommitdiffstats
path: root/specgen.sh
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2000-02-18 03:41:53 +0000
committerEric S. Raymond <esr@thyrsus.com>2000-02-18 03:41:53 +0000
commitcf6c6a28b0631a29085ceeca86c980c0a6e4022d (patch)
treeaa10931caa577ef8f37d690f7f05dd970ab1ce83 /specgen.sh
parentc5cfa5bee8bb00850ef37062e68e542b02a87d6b (diff)
downloadfetchmail-cf6c6a28b0631a29085ceeca86c980c0a6e4022d.tar.gz
fetchmail-cf6c6a28b0631a29085ceeca86c980c0a6e4022d.tar.bz2
fetchmail-cf6c6a28b0631a29085ceeca86c980c0a6e4022d.zip
Various minor bug fixes.
svn path=/trunk/; revision=2757
Diffstat (limited to 'specgen.sh')
-rwxr-xr-xspecgen.sh25
1 files changed, 11 insertions, 14 deletions
diff --git a/specgen.sh b/specgen.sh
index 34ff7970..08c27b11 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -1,12 +1,8 @@
cat <<EOF
# Note: Do not hack fetchmail.spec by hand -- it's generated by specgen.sh
-%define name fetchmail
-%define version ${1}
-%define release 1
-%define builddir \$RPM_BUILD_DIR/%{name}-%{version}
-Name: %{name}
-Version: %{version}
-Release: %{release}
+Name: fetchmail
+Version: $1
+Release: 1
Vendor: Eric Conspiracy Secret Labs
Packager: Eric S. Raymond <esr@thyrsus.com>
URL: http://www.tuxedo.org/~esr/fetchmail
@@ -119,23 +115,24 @@ GUI konfigurator do fetchmaila napisany w pythonie.
%setup -q
%build
-CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" # Add --enable-nls --without-included-gettext for internationalization
+CFLAGS="\$RPM_OPT_FLAGS" LDFLAGS="-s"
export CFLAGS LDFLAGS
-./configure -prefix=/usr
+./configure -prefix=/usr # Add --enable-nls --without-included-gettext
+ # for internationalization. Also look below.
make
%install
if [ -d \$RPM_BUILD_ROOT ]; then rm -rf \$RPM_BUILD_ROOT; fi
mkdir -p \$RPM_BUILD_ROOT/{etc/X11/wmconfig,usr/lib/rhs/control-panel}
make install prefix=\$RPM_BUILD_ROOT/usr
-cp %{builddir}/rh-config/*.{xpm,init} \$RPM_BUILD_ROOT/usr/lib/rhs/control-panel
-cp %{builddir}/fetchmail.man \$RPM_BUILD_ROOT/usr/man/man1/fetchmail.1
+cp rh-config/*.{xpm,init} \$RPM_BUILD_ROOT/usr/lib/rhs/control-panel
+cp fetchmail.man \$RPM_BUILD_ROOT/usr/man/man1/fetchmail.1
gzip -9nf \$RPM_BUILD_ROOT/usr/man/man1/fetchmail.1
+rm -rf contrib/RCS
+chmod 644 contrib/*
+cp rh-config/fetchmailconf.wmconfig \$RPM_BUILD_ROOT/etc/X11/wmconfig/fetchmailconf
cd \$RPM_BUILD_ROOT/usr/man/man1
ln -sf fetchmail.1.gz fetchmailconf.1.gz
-rm -rf %{builddir}/contrib/RCS
-chmod 644 %{builddir}/contrib/*
-cp %{builddir}/rh-config/fetchmailconf.wmconfig \$RPM_BUILD_ROOT/etc/X11/wmconfig/fetchmailconf
%clean
rm -rf \$RPM_BUILD_ROOT