aboutsummaryrefslogtreecommitdiffstats
path: root/makerelease
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-04-30 02:23:18 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-04-30 02:23:18 +0000
commit6efc562bccfcf4484e8c18ee98296e0c1fb60eac (patch)
tree2d09ae432285c5336534f58280a09b757787f440 /makerelease
parent1c3edbd0d1044fad7137a8e5d80d855acab803e7 (diff)
downloadfetchmail-6efc562bccfcf4484e8c18ee98296e0c1fb60eac.tar.gz
fetchmail-6efc562bccfcf4484e8c18ee98296e0c1fb60eac.tar.bz2
fetchmail-6efc562bccfcf4484e8c18ee98296e0c1fb60eac.zip
Correct logfile updating.
svn path=/trunk/; revision=2461
Diffstat (limited to 'makerelease')
-rwxr-xr-xmakerelease12
1 files changed, 9 insertions, 3 deletions
diff --git a/makerelease b/makerelease
index b3644b6a..303678d3 100755
--- a/makerelease
+++ b/makerelease
@@ -12,7 +12,7 @@ sub rfc822date
@months = ("Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Nov", "Dec");
my($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = gmtime(time());
- "$wdays[$wday] $months[$mon] " . substr("0$mday", -2) . " " . substr("0$hour", -2) . ":" . substr("0$min", -2) . ":" . substr("0$sec", -2) . " $timezone " . (1900+$year);
+ "$wdays[$wday], $months[$mon] " . substr("0$mday", -2) . " " . substr("0$hour", -2) . ":" . substr("0$min", -2) . ":" . substr("0$sec", -2) . " $timezone " . (1900+$year);
}
@@ -61,8 +61,9 @@ if ($version eq $logvers) {
} else {
$date = &rfc822date();
print "Updating the Debian logfile ($logvers -> $version)...\n";
- open(DEBLOG, ">>debian/changelog");
- print DEBLOG <<EOF;
+ open(DEBLOG, "<debian/changelog");
+ open(TMP, ">mkr$$.tmp") || die("Error opening temp file\n");
+ print TMP <<EOF;
fetchmail (${version}-1) unstable; urgency=low
* new upstream version
@@ -70,7 +71,12 @@ fetchmail (${version}-1) unstable; urgency=low
-- Eric S. Raymond <esr\@thyrsus.com> ${date}
EOF
+ while (<DEBLOG>) {
+ print TMP $_;
+ }
+ close(TMP);
close(DEBLOG);
+ system("mv mkr$$.tmp debian/changelog");
}
print "Building the distribution...\n";