aboutsummaryrefslogtreecommitdiffstats
path: root/makerelease
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-04-01 06:22:40 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-04-01 06:22:40 +0000
commit35136c70cbd3cee9a18c7246895dd040bc35d90f (patch)
treed1525632f1fe398f3418491a5c16af4d8dc69478 /makerelease
parentddef53c977e35c7a639295c34fc4f5855728ab90 (diff)
downloadfetchmail-35136c70cbd3cee9a18c7246895dd040bc35d90f.tar.gz
fetchmail-35136c70cbd3cee9a18c7246895dd040bc35d90f.tar.bz2
fetchmail-35136c70cbd3cee9a18c7246895dd040bc35d90f.zip
Add Debian changelog update.
svn path=/trunk/; revision=2423
Diffstat (limited to 'makerelease')
-rwxr-xr-xmakerelease22
1 files changed, 22 insertions, 0 deletions
diff --git a/makerelease b/makerelease
index 64050620..55e0e86c 100755
--- a/makerelease
+++ b/makerelease
@@ -38,6 +38,28 @@ if (system("su -c 'make >/dev/null' esr")) {
die("Compilation failure\n");
}
+# Update the Debian logfile
+open(DEBLOG, "debian/changelog");
+$firstline = <DEBLOG>;
+close(DEBLOG);
+$firstline =~ /fetchmail \(*([^-]*)/;
+$logvers = $1;
+if ($version eq $logvers) {
+ print "No change to Debian logfile...\n";
+} else {
+ print "Updating the Debian logfile ($logvers -> $version)...\n";
+ open(DEBLOG, ">>debian/changelog");
+ print DEBLOG <<EOF;
+fetchmail (${version}-1) unstable; urgency=low
+
+ * new upstream version
+
+-- Eric S. Raymond <esr\@ccil.org> ${date}
+
+EOF
+ close(DEBLOG);
+}
+
print "Building the distribution...\n";
if (system("su -c 'make dist >/dev/null' esr")) {
die("Distribution-build failure\n");