aboutsummaryrefslogtreecommitdiffstats
path: root/dist-tools/git-commit-po-updates.sh
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2020-08-27 18:27:03 +0200
committerMatthias Andree <matthias.andree@gmx.de>2020-08-27 19:04:44 +0200
commit7e89e880194e38c087099312c56631d84eddf4cb (patch)
treede3401e73a0a2a696fc18d4b873948b4e78c5876 /dist-tools/git-commit-po-updates.sh
parentcddf65c3f55a2a8ec000d4e8505ecb686726c7cc (diff)
downloadfetchmail-7e89e880194e38c087099312c56631d84eddf4cb.tar.gz
fetchmail-7e89e880194e38c087099312c56631d84eddf4cb.tar.bz2
fetchmail-7e89e880194e38c087099312c56631d84eddf4cb.zip
Makefile.am, dist-tools: check for new translations in dist-hook
Diffstat (limited to 'dist-tools/git-commit-po-updates.sh')
-rwxr-xr-xdist-tools/git-commit-po-updates.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/dist-tools/git-commit-po-updates.sh b/dist-tools/git-commit-po-updates.sh
index 969acd31..41b1f65a 100755
--- a/dist-tools/git-commit-po-updates.sh
+++ b/dist-tools/git-commit-po-updates.sh
@@ -11,6 +11,12 @@
# Supported modes:
# -n: dry-run, only print commands, but do not run them.
# -c: commit, print commands and run them.
+
+# Exit codes:
+# 0: success, no new po/*.po files.
+# 1: error
+# 2: usage was printed, nothing was done
+# 3: new po/*.po files detected
set -eu
@@ -122,6 +128,7 @@ if [ -n "$new_po_files" ] ; then
printf " %s" "$j"
done
printf '\n'
+ rc=3
fi
exit $rc