aboutsummaryrefslogtreecommitdiffstats
path: root/dist-tools/getstats.py
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2021-11-20 17:08:42 +0100
committerMatthias Andree <matthias.andree@gmx.de>2021-11-21 00:33:34 +0100
commitf3d5722682201383f6c3d23dd9c8b51a47f90b01 (patch)
tree895aa7b387fa7b754b755b3df193b4518000df81 /dist-tools/getstats.py
parent0d32056e7b14bd029aa375f59230a3ad3e2bae51 (diff)
downloadfetchmail-f3d5722682201383f6c3d23dd9c8b51a47f90b01.tar.gz
fetchmail-f3d5722682201383f6c3d23dd9c8b51a47f90b01.tar.bz2
fetchmail-f3d5722682201383f6c3d23dd9c8b51a47f90b01.zip
getstats.py: count .am/.ac files.
Diffstat (limited to 'dist-tools/getstats.py')
-rwxr-xr-xdist-tools/getstats.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/dist-tools/getstats.py b/dist-tools/getstats.py
index ad52f464..4c45318b 100755
--- a/dist-tools/getstats.py
+++ b/dist-tools/getstats.py
@@ -12,7 +12,7 @@ from datetime import date
# Get version and date
with tempfile.TemporaryDirectory() as tmpdirname:
subprocess.check_call("git archive --format=tar HEAD | ( cd {} && tar -xf -)".format(tmpdirname), shell=True)
- LOC = subprocess.getoutput("cat {0}/*.[chly] {0}/*.py 2>/dev/null | wc -l".format(tmpdirname)).strip()
+ LOC = subprocess.getoutput("cat {0}/*.[chly] {0}/*.a[cm] {0}/*.py 2>/dev/null | wc -l".format(tmpdirname)).strip()
try:
with open("configure.ac") as f:
AC_INIT = list(filter(lambda x: re.match('AC_INIT', x),