aboutsummaryrefslogtreecommitdiffstats
path: root/dist-tools/getstats.py
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2021-03-07 15:08:26 +0100
committerMatthias Andree <matthias.andree@gmx.de>2021-03-07 15:08:26 +0100
commitc52a48fec38cef4ad513c6cfa64579a8f057a0aa (patch)
tree3a3c3be5dde05682b948f15b1a993603974a30b4 /dist-tools/getstats.py
parentef93b25048b1960d9fa03cc6e923b0d1bc181db2 (diff)
downloadfetchmail-c52a48fec38cef4ad513c6cfa64579a8f057a0aa.tar.gz
fetchmail-c52a48fec38cef4ad513c6cfa64579a8f057a0aa.tar.bz2
fetchmail-c52a48fec38cef4ad513c6cfa64579a8f057a0aa.zip
getstats.py: count *.py files, too
Diffstat (limited to 'dist-tools/getstats.py')
-rwxr-xr-xdist-tools/getstats.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/dist-tools/getstats.py b/dist-tools/getstats.py
index 4586e361..ad52f464 100755
--- a/dist-tools/getstats.py
+++ b/dist-tools/getstats.py
@@ -12,7 +12,7 @@ from datetime import date
# Get version and date
with tempfile.TemporaryDirectory() as tmpdirname:
subprocess.check_call("git archive --format=tar HEAD | ( cd {} && tar -xf -)".format(tmpdirname), shell=True)
- LOC = subprocess.getoutput("cat {}/*.[chly] 2>/dev/null | wc -l".format(tmpdirname)).strip()
+ LOC = subprocess.getoutput("cat {0}/*.[chly] {0}/*.py 2>/dev/null | wc -l".format(tmpdirname)).strip()
try:
with open("configure.ac") as f:
AC_INIT = list(filter(lambda x: re.match('AC_INIT', x),