aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2004-01-13 07:59:24 +0000
committerEric S. Raymond <esr@thyrsus.com>2004-01-13 07:59:24 +0000
commitffec0cb82f160994b2ceeeca5d4c2d82f2f0d098 (patch)
treedf894c4ab2db18c9382c34ccf17ca374ac83736c /configure.in
parent804b8ab96632e19c713a900ede3f87d7f71fbc11 (diff)
downloadfetchmail-ffec0cb82f160994b2ceeeca5d4c2d82f2f0d098.tar.gz
fetchmail-ffec0cb82f160994b2ceeeca5d4c2d82f2f0d098.tar.bz2
fetchmail-ffec0cb82f160994b2ceeeca5d4c2d82f2f0d098.zip
Applied GSS library support patch.
svn path=/trunk/; revision=3877
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f7137f91..a24f96a3 100644
--- a/configure.in
+++ b/configure.in
@@ -705,6 +705,9 @@ then
LDFLAGS="$LDFLAGS -L$with_gssapi/lib"
fi
+ AC_CHECK_LIB(gss, gss_check_version, LIBS="$LIBS -lgss", nogss=t)
+ if test -n "$nogss"
+ then
if test -f "$with_gssapi/include/roken.h"
then
LIBS="$LIBS -lkrb5 -lasn1 -ldes -lroken -ldb -ldl"
@@ -715,10 +718,11 @@ then
AC_CHECK_LIB(gssapi_krb5, gss_init_sec_context,LIBS="$LIBS -lgssapi_krb5",
AC_MSG_ERROR([could not find libgssapi_krb5 which is needed for GSSAPI support]), -lkrb5)
fi
+ fi
AC_DEFINE(GSSAPI)
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="-I$with_gssapi/include"
- AC_CHECK_HEADERS(gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
+ AC_CHECK_HEADERS(gss.h gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
if test "$ac_cv_header_gssapi_h" = "yes"; then
AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
else