aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1998-01-23 16:47:42 +0000
committerEric S. Raymond <esr@thyrsus.com>1998-01-23 16:47:42 +0000
commitdc978c56e3fbbe9c8e3f8da4eef6c5fd3f8a509c (patch)
tree8b3fb8eb711e9f1ca769673cc0a0f65e31fa328f /configure.in
parentaaae0969da7c59808ca238a085dbd63fccad8935 (diff)
downloadfetchmail-dc978c56e3fbbe9c8e3f8da4eef6c5fd3f8a509c.tar.gz
fetchmail-dc978c56e3fbbe9c8e3f8da4eef6c5fd3f8a509c.tar.bz2
fetchmail-dc978c56e3fbbe9c8e3f8da4eef6c5fd3f8a509c.zip
Corrected OTP support.
svn path=/trunk/; revision=1610
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 5 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 677ef6f3..3a51afa1 100644
--- a/configure.in
+++ b/configure.in
@@ -182,19 +182,13 @@ AC_ARG_ENABLE(RPA,
[with_RPA=no])
test "$with_RPA" = "yes" && AC_DEFINE(RPA_ENABLE)
-### use option --enable-OPIE to compile in the OPIE support
+### use option --enable-opie to compile in the OPIE support
AC_ARG_ENABLE(opie,
- [ --enable-OPIE support OTP through the OPIE library],
- [with_opie=$enableval],
+ [ --enable-opie support OTP through the OPIE library],
+ [ AC_CHECK_HEADER(opie.h,, [echo 'configure: cannot find <opie.h>, which is required for OPIE support.'; exit 1])
+ AC_CHECK_LIB(opie,opiegenerator,, [echo 'configure: cannot find libopie, which is required for OPIE support.'; exit 1])
+ AC_DEFINE(OPIE,1) ],
[with_opie=no])
-if test "$with_opie" = "yes";
-then
- AC_CHECK_HEADER(opie.h,,
- [echo 'configure: cannot find <opie.h>, which is required for OPIE support.'; exit 1])
- AC_CHECK_LIB(opie,opiegenerator,,
- [echo 'configure: cannot find libopie, which is required for OPIE support.'; exit 1])
- AC_DEFINE(OPIE,1)
-fi
### use option --with-gssapi=DIR to compile in GSSAPI support
AC_ARG_WITH(gssapi,