aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-03-07 08:44:34 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-03-07 08:44:34 +0000
commitceca8872529ac73d4fc115c6bb3d8bb1ef7cffe3 (patch)
tree1804deaf465e176645f211385ccde45b6402c39e /configure.in
parent445ba9b0b522fb868ae1cc0079719cb7fbb4c074 (diff)
downloadfetchmail-ceca8872529ac73d4fc115c6bb3d8bb1ef7cffe3.tar.gz
fetchmail-ceca8872529ac73d4fc115c6bb3d8bb1ef7cffe3.tar.bz2
fetchmail-ceca8872529ac73d4fc115c6bb3d8bb1ef7cffe3.zip
Set FALLBACK_MDA.
svn path=/trunk/; revision=3212
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c69d4d76..d8544126 100644
--- a/configure.in
+++ b/configure.in
@@ -206,6 +206,15 @@ done
AC_MSG_RESULT(root-mode pid file will go in $dir)
AC_DEFINE_UNQUOTED(PID_DIR, "$dir")
+# We may have a fallback MDA available in case the socket open to the
+# local SMTP listener fails...
+AC_PATH_PROG(procmail, procmail, "", $PATH:/usr/sbin)
+if test "$procmail"
+then
+ echo "Found procmail, will use it as a fallback MDA."
+ AC_DEFINE(FALLBACK_MDA, "$procmail -d %T")
+fi
+
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)