aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-03-12 04:58:53 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-03-12 04:58:53 +0000
commitbdd4f9d5b178e7646b95ae97c7b7629256b6edaa (patch)
treea7ac24fbc37814325e5461e92002e87207716cc6 /configure.in
parentc71c95b401a49a69281af562062375c85592074d (diff)
downloadfetchmail-bdd4f9d5b178e7646b95ae97c7b7629256b6edaa.tar.gz
fetchmail-bdd4f9d5b178e7646b95ae97c7b7629256b6edaa.tar.bz2
fetchmail-bdd4f9d5b178e7646b95ae97c7b7629256b6edaa.zip
HMH autoconf cleanup.
svn path=/trunk/; revision=3241
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 19 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index c1cbe481..8d07ee66 100644
--- a/configure.in
+++ b/configure.in
@@ -11,6 +11,25 @@ dnl We want these before the checks, so the checks can modify their values.
test -z "$CFLAGS" && CFLAGS="-O" AC_SUBST(CFLAGS)
test -z "$LDFLAGS" && LDFLAGS=AC_SUBST(LDFLAGS)
+PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
+VERSION=`sed -n '/VERSION *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
+AM_INIT_AUTOMAKE("$PACKAGE", "$VERSION")
+
+dnl Map autoconf, autoheader and aclocal to (/bin/true) if they are
+dnl not available in the system, so as not to cause problems in
+dnl Makefile.in. Be sure to fix this hack if we start supporting
+dnl automake (Makefile.am).
+
+if test -z "$AUTOCONF" ; then
+ AUTOCONF=true
+fi
+if test -z "$ACLOCAL" ; then
+ ACLOCAL=true
+fi
+if test -z "$AUTOHEADER" ; then
+ AUTOHEADER=true
+fi
+
AC_CANONICAL_HOST
AC_PROG_CC
AC_PROG_INSTALL
@@ -36,14 +55,6 @@ AC_SUBST(CEFLAGS)
AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
-PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
-AC_SUBST(PACKAGE)
-
-VERSION=`sed -n '/VERSION *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION")
-AC_SUBST(VERSION)
-
# Check for LynxOS special case: -lbsd needed (at least on 2.3.0) and -s
# not working.
if test `uname` = "LynxOS"