aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-09-26 14:32:49 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-09-26 14:32:49 +0000
commitb04887513f9f1ddbe509ec67f3dd812612f135a5 (patch)
treee9c47af68b0c0718c9855d7e6a9babbf637da0b3 /configure.in
parent2e4e5a1af29d5ce749b90f33db8153c81c6936bf (diff)
downloadfetchmail-b04887513f9f1ddbe509ec67f3dd812612f135a5.tar.gz
fetchmail-b04887513f9f1ddbe509ec67f3dd812612f135a5.tar.bz2
fetchmail-b04887513f9f1ddbe509ec67f3dd812612f135a5.zip
Ready to ship.
svn path=/trunk/; revision=3491
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e893585b..710a93fc 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,15 @@ directory],
[
if test "$with_kerberos5" != "no"
then
+# Check for a OpenBSD special case
+if test "$with_kerberos5" = "yes" && ( test `uname` = "OpenBSD" )
+then
+ AC_CHECKING([kerberosV for OpenBSD])
+ AC_DEFINE(HEIMDAL)
+ AC_DEFINE(KERBEROS_V5)
+ CEFLAGS="$CEFLAGS -I/usr/include/kerberosV"
+ LIBS="$LIBS -lasn1 -lkrb5 -lcom_err"
+else
if test "$with_kerberos5" != "yes"
then
LDEFLAGS="$LDEFLAGS -L${with_kerberos5}/lib"
@@ -446,6 +455,7 @@ then
AC_ERROR([Kerberos 5 libraries not found])
fi
fi
+fi
]) dnl --with-kerberos5=DIR
### use option --with-kerberos=DIR to point at a Kerberos 4 directory