aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1998-10-20 06:40:04 +0000
committerEric S. Raymond <esr@thyrsus.com>1998-10-20 06:40:04 +0000
commita6e33f26b17202e4fddec64a56d9c272b537f73d (patch)
tree863f88840eb4b155dcd1acfd22f5ab431ae02333 /configure.in
parenta8fb4194926aa22732192b37768be34aec0c9360 (diff)
downloadfetchmail-a6e33f26b17202e4fddec64a56d9c272b537f73d.tar.gz
fetchmail-a6e33f26b17202e4fddec64a56d9c272b537f73d.tar.bz2
fetchmail-a6e33f26b17202e4fddec64a56d9c272b537f73d.zip
-Wall cleanup, second phase.
svn path=/trunk/; revision=2121
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3359249b..5ec3cdbc 100644
--- a/configure.in
+++ b/configure.in
@@ -108,6 +108,13 @@ AC_TRY_COMPILE([],
[AC_DEFINE(HAVE_VOIDPOINTER) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
+dnl Check for ANSI volatile
+AC_MSG_CHECKING(for ANSI volatile)
+AC_TRY_COMPILE([],
+ [volatile int n;],
+ [AC_DEFINE(HAVE_VOLATILE) AC_MSG_RESULT(yes)],
+ AC_MSG_RESULT(no))
+
dnl Check out the wait reality. We have to assume sys/wait.h is present.
AC_CHECK_FUNCS(waitpid wait3)
AC_MSG_CHECKING(for union wait);