aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2000-03-11 00:59:57 +0000
committerEric S. Raymond <esr@thyrsus.com>2000-03-11 00:59:57 +0000
commit788d69daa64652cd382aa58a2c8ac3cbdea9b6b1 (patch)
tree612e8e46dca7341a8b08b0c2a718d7f0ff6a83a9 /configure.in
parenteb0e319b174a73671c41cffcac3a913bbe0ed5ba (diff)
downloadfetchmail-788d69daa64652cd382aa58a2c8ac3cbdea9b6b1.tar.gz
fetchmail-788d69daa64652cd382aa58a2c8ac3cbdea9b6b1.tar.bz2
fetchmail-788d69daa64652cd382aa58a2c8ac3cbdea9b6b1.zip
Better SOCKS5 support.
svn path=/trunk/; revision=2815
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b25e9d0c..6e06e7d5 100644
--- a/configure.in
+++ b/configure.in
@@ -500,6 +500,24 @@ then
LIBS="-lsocks $LIBS"
fi])
+### use option --with-socks5=DIR to point at SOCKS library
+AC_ARG_WITH(socks5,
+ [ --with-socks5[=DIR] add built-in SOCKS5 firewall access],
+[
+if test "$with_socks5" != no
+then
+ if test "$with_socks5" != yes
+ then
+ LDEFLAGS="$LDEFLAGS -L$with_socks5"
+ else
+ AC_CHECK_LIB(socks5, SOCKSconnect,,
+ AC_MSG_ERROR([could not find libsocks5 which is needed for built-in SOCKS5 support]))
+ fi
+ AC_DEFINE(HAVE_SOCKS)
+ CEFLAGS="$CEFLAGS -Dconnect=SOCKSconnect -Dgetsockname=SOCKSgetsockname -Dbind=SOCKSbind -Daccept=SOCKSaccept -Dlisten=SOCKSlisten -Dselect=SOCKSselect-Drecvfrom=SOCKSrecvfrom -Dsendto=SOCKSsendto -Drecv=SOCKSrecv -Dsend=SOCKSsend-Dread=SOCKSread -Dwrite=SOCKSwrite -Drresvport=SOCKSrresvport-Dshutdown=SOCKSshutdown -Dlisten=SOCKSlisten -Dclose=SOCKSclose -Ddup=SOCKSdup-Ddup2=SOCKSdup2 -Dfclose=SOCKSfclose -Dgethostbyname=SOCKSgethostbyname"
+ LIBS="-lsocks5 $LIBS"
+fi])
+
### use option --with-hesiod=DIR to point at a HESIOD directory
AC_ARG_WITH(hesiod,
[ --with-hesiod=DIR point fetchmail compilation at a HESIOD directory])