aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1998-03-03 21:22:36 +0000
committerEric S. Raymond <esr@thyrsus.com>1998-03-03 21:22:36 +0000
commit6421b138290aeecda414de1c753ace9d04681f7c (patch)
tree4facf1555bb3adc7028734a8f5c201b4c3c4a896 /configure.in
parente82d0241ff7d9a09e30776dc37b97d49c1ca531a (diff)
downloadfetchmail-6421b138290aeecda414de1c753ace9d04681f7c.tar.gz
fetchmail-6421b138290aeecda414de1c753ace9d04681f7c.tar.bz2
fetchmail-6421b138290aeecda414de1c753ace9d04681f7c.zip
Kerberos V support.
svn path=/trunk/; revision=1682
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8fd6d8e7..b9354b94 100644
--- a/configure.in
+++ b/configure.in
@@ -265,6 +265,31 @@ else
done
fi
+### use option --with-kerberos5=DIR to point at a Kerberos 5 directory
+AC_ARG_WITH(kerberos5,
+ [ --with-kerberos5=DIR point fetchmail compilation at a Kerberos 5 directory])
+
+# The "then" arm (nonempty $with_kerberos5) is kind of a crock. It works for
+# configuring the BSD/OS Kerberos IV support, though.
+if test "$with_kerberos5" != "yes"
+then
+ # Path given
+ CEFLAGS="$CEFLAGS -DKERBEROS_V5 -I$with_kerberos5/include"
+ LDEFLAGS="$LDEFLAGS -L$with_kerberos5/lib"
+ LIBS="$LIBS -lkrb5 -lcrypto -lcom_err"
+else
+ for dir in /usr/kerberos /usr/local/krb5 /usr/athena
+ do
+ if test -f "$dir/include/krb5.h"
+ then
+ CEFLAGS="$CEFLAGS -DKERBEROS_V5 -I$dir/include"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
+ LIBS="$LIBS -lkrb5 -lcrypto -lcom_err"
+ break
+ fi
+ done
+fi
+
AC_OUTPUT(Makefile, [
# The reason for this odd makedepend line is that we want
# to have all dependencies evaluated relative to the source directory