aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-09-03 19:35:00 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-09-03 19:35:00 +0000
commit5c29fed4f72c7558ae15ed2c0b1268bab61a0321 (patch)
treee7c25b4c5c585d85d9b3c95d75367e52f2c27205 /configure.in
parentfca5b6d8eeebbb9782df5dc22e17ef2ca1c1e9ad (diff)
downloadfetchmail-5c29fed4f72c7558ae15ed2c0b1268bab61a0321.tar.gz
fetchmail-5c29fed4f72c7558ae15ed2c0b1268bab61a0321.tar.bz2
fetchmail-5c29fed4f72c7558ae15ed2c0b1268bab61a0321.zip
sysV68 R3V7.1 port changes.
svn path=/trunk/; revision=1282
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d406ab2c..562f4fa9 100644
--- a/configure.in
+++ b/configure.in
@@ -31,9 +31,16 @@ AC_PROG_LEX
AC_PROG_YACC
AC_SUBST(LIBOBJS)
+# Under sysV68, socket and friends are provided by the C library.
+# -linet does not provide socket, but causes multiple definition
+# errors at link-time. It is thus better to only use the C library.
+# So don't add -linet to the link list unless it's necessary
+AC_CHECK_FUNC(socket,
+ AC_MSG_RESULT(using libc's socket),
+ AC_CHECK_LIB(socket,socket)
+ AC_CHECK_LIB(inet,socket))
+
AC_CHECK_LIB(nsl,inet_addr)
-AC_CHECK_LIB(socket,socket)
-AC_CHECK_LIB(inet,socket)
AC_CHECK_LIB(opie,opiegenerator)
dnl Port hack for Interactive UNIX System V/386 Release 3.2