aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-03-06 08:20:34 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-03-06 08:20:34 +0000
commit5866b49d6ffb34a21bb3ad8925cb4a77cd12a4da (patch)
treea9051bfa9965694554b48780b73ab60b6e7dbcd2 /configure.in
parent14d36160185cd458d0bc83fd7886be92938b4f61 (diff)
downloadfetchmail-5866b49d6ffb34a21bb3ad8925cb4a77cd12a4da.tar.gz
fetchmail-5866b49d6ffb34a21bb3ad8925cb4a77cd12a4da.tar.bz2
fetchmail-5866b49d6ffb34a21bb3ad8925cb4a77cd12a4da.zip
HMH's configure fix
svn path=/trunk/; revision=3210
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 3 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index 6c7a2e71..c69d4d76 100644
--- a/configure.in
+++ b/configure.in
@@ -34,8 +34,6 @@ AC_SUBST(CPFLAGS)
AC_SUBST(CEFLAGS)
AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
-AC_SUBST(POMAKE)
-AC_SUBST(LOCALE_DIR)
PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
@@ -70,12 +68,10 @@ then
LDFLAGS=`echo $LDFLAGS | sed "s/-s //"`
fi
-# i18n
+dnl i18n
ALL_LINGUAS="cs es fr pl pt_BR gl da"
-
AM_GNU_GETTEXT
-
-# end i18n
+dnl end i18n
# Under sysV68, socket and friends are provided by the C library.
# -linet does not provide socket, but causes multiple definition
@@ -86,16 +82,6 @@ AC_CHECK_FUNC(socket,
AC_CHECK_LIB(socket,socket)
AC_CHECK_LIB(inet,socket))
-# If gettext isn't in the C library, maybe there's a -lintl. However,
-# do not check if user has specified --with-included-gettext. On
-# some systems (e.g. Solaris), there is a gettext in libc which
-# we do not want to use if --with-included-gettext is specified.
-if test x$nls_cv_force_use_gnu_gettext != xyes; then
- AC_CHECK_FUNC(gettext,
- AC_MSG_RESULT(using libc's gettext),
- AC_CHECK_LIB(intl,gettext))
-fi
-
# The condition in this test copes with the presence of inet_addr in libc6.
AC_CHECK_FUNC(inet_addr,
AC_MSG_RESULT(using libc's inet_addr),
@@ -224,21 +210,6 @@ AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
-if test "$USE_NLS" = "yes"
-then
- echo 'Enabling internationalization support...'
- POMAKE='cd po; $(MAKE)'
- if test "x$prefix" != xNONE; then
- LOCALE_DIR=$prefix/share/locale
- else
- LOCALE_DIR=$ac_default_prefix/share/locale
- fi
- EXTRADEFS="$EXTRADEFS -DLOCALEDIR='\"${LOCALE_DIR}\"'"
-else
- echo 'Disabling internationalization support...'
- POMAKE="@echo '(NLS support disabled)'; #"
-fi
-
### use option --enable-POP2 to compile in the POP2 support
AC_ARG_ENABLE(POP2,
[ --enable-POP2 compile in POP2 protocol support (obsolete)],
@@ -625,7 +596,7 @@ then
fi
fi])
-AC_OUTPUT([Makefile po/Makefile.in], [
+AC_OUTPUT([Makefile intl/Makefile po/Makefile.in], [
# The reason for this odd makedepend line is that we want
# to have all dependencies evaluated relative to the source directory
# and let VPATH do all the dirty work when we build remotely