aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-10-15 14:48:34 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-10-15 14:48:34 +0000
commit4c2423a98542de4ab80ff75cb5987aa59f788ee1 (patch)
treee27ebc534bd4815c5b51ecf8f35f4640336d7c17 /configure.in
parentc1e1a25354f0072bf6bb871361f0316ed4e90593 (diff)
downloadfetchmail-4c2423a98542de4ab80ff75cb5987aa59f788ee1.tar.gz
fetchmail-4c2423a98542de4ab80ff75cb5987aa59f788ee1.tar.bz2
fetchmail-4c2423a98542de4ab80ff75cb5987aa59f788ee1.zip
Simplify the autoconfig process a lot.
svn path=/trunk/; revision=337
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 2 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index b52f6bbe..d9a0aa55 100644
--- a/configure.in
+++ b/configure.in
@@ -23,7 +23,7 @@ AC_HEADER_STDC
AC_TYPE_SIZE_T
AC_TYPE_PID_T
AC_TYPE_SIGNAL
-AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h memory.h)
+AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h)
AC_C_CONST dnl getopt needs this.
@@ -34,10 +34,6 @@ AC_SUBST(LIBOBJS)
AC_CHECK_LIB(socket,socket)
AC_CHECK_LIB(nsl,inet_addr)
-AC_CHECK_FUNC(strdup, AC_DEFINE(HAVE_STRDUP),
- [EXTRASRC="$EXTRASRC \$(srcdir)/strdup.c"
- EXTRAOBJ="$EXTRAOBJ strdup.o"])
-
AC_CHECK_FUNC(strcasecmp, AC_DEFINE(HAVE_STRCASECMP),
[EXTRASRC="$EXTRASRC \$(srcdir)/strcasecmp.c"
EXTRAOBJ="$EXTRAOBJ strcasecmp.o"])
@@ -65,7 +61,7 @@ dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
AC_SUBST(EXTRASRC)
AC_SUBST(EXTRAOBJ)
-AC_CHECK_FUNCS(dup2 strerror tcsetattr stty setsid rresvport)
+AC_CHECK_FUNCS(tcsetattr stty setsid rresvport)
dnl AC_FUNC_SETVBUF_REVERSED
@@ -119,12 +115,6 @@ AC_TRY_LINK([#include <signal.h>
[AC_DEFINE(SYS_SIGLIST_DECLARED) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
-# The presence of the following is not meant to imply
-# that fetchmail necessarily works on those systems.
-dnl AC_DYNIX_SEQ
-dnl AC_XENIX_DIR
-dnl AC_IRIX_SUN
-
AC_OUTPUT(Makefile, [
# Makefile uses this timestamp file to know when to remake Makefile,
# build.sh, and glob/Makefile.