aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-06-27 06:57:36 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-06-27 06:57:36 +0000
commit4917514b49d5893d2bc71f5d2deb021c646da1ed (patch)
treef239f9284e1868ab60c0131b13724526f3980593 /configure.in
parent10bd337ff3891c96bec7719e926bd11842519c5f (diff)
downloadfetchmail-4917514b49d5893d2bc71f5d2deb021c646da1ed.tar.gz
fetchmail-4917514b49d5893d2bc71f5d2deb021c646da1ed.tar.bz2
fetchmail-4917514b49d5893d2bc71f5d2deb021c646da1ed.zip
First cut at being able to specify a Kerberos directory.
svn path=/trunk/; revision=1125
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index d98ceff8..2b0d8933 100644
--- a/configure.in
+++ b/configure.in
@@ -55,20 +55,6 @@ then
EXTRAOBJ="$EXTRAOBJ alloca.o"
fi
-if test -f "/usr/kerberos/include/krb.h"
-then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I/usr/kerberos/include"
- LDFLAGS="$LDFLAGS -L/usr/kerberos/lib"
- LIBS="$LIBS -lkrb -ldes"
-fi
-
-if test -f "/usr/athena/include/krb.h"
-then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I/usr/athena/include"
- LDFLAGS="$LDFLAGS -L/usr/athena/lib"
- LIBS="$LIBS -lkrb -ldes"
-fi
-
dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
AC_SUBST(EXTRASRC)
@@ -138,6 +124,20 @@ AC_ARG_ENABLE(POP2,
[with_POP2=no])
test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
+### use option --with-kerberos=DIR to point at a Kerberos directory
+AC_ARG_WITH(kerberos,
+ [ --with-kerberos=DIR point fetchmail compilation at a Kerberos directory])
+
+for dir in $with_kerberos /usr/kerberos /usr/athena
+do
+ if test -f "$dir/include/krb.h"
+ then
+ CFLAGS="$CFLAGS -DKERBEROS_V4 -I$dir/include"
+ LDFLAGS="$LDFLAGS -L$dir/lib"
+ LIBS="$LIBS -lkrb -ldes"
+ fi
+done
+
AC_OUTPUT(Makefile, [
# Makefile uses this timestamp file to know when to remake Makefile,
# build.sh, and glob/Makefile.