aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-10-04 14:29:37 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-10-04 14:29:37 +0000
commit313a954360f1659a3a27e1b02c8de7d2aaf99e15 (patch)
treeed4ec54503517e0b5939a6b08b25c61d7674bedc /configure.in
parent8a8b194fae862aa28acc0fd38962423a98e44ef0 (diff)
downloadfetchmail-313a954360f1659a3a27e1b02c8de7d2aaf99e15.tar.gz
fetchmail-313a954360f1659a3a27e1b02c8de7d2aaf99e15.tar.bz2
fetchmail-313a954360f1659a3a27e1b02c8de7d2aaf99e15.zip
Enable conditioning out of POP3, IMAP, ETRN.
svn path=/trunk/; revision=1477
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 16b81a11..32f756b3 100644
--- a/configure.in
+++ b/configure.in
@@ -154,6 +154,27 @@ AC_ARG_ENABLE(POP2,
[with_POP2=no])
test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
+### use option --disable-POP3 to omit the POP3 support
+AC_ARG_ENABLE(POP3,
+ [ --disable-POP3 don't compile in POP3 protocol support],
+ [with_POP3=$enableval],
+ [with_POP3=yes])
+test "$with_POP3" = "yes" && AC_DEFINE(POP3_ENABLE)
+
+### use option --disable-IMAP to omit the IMAP support
+AC_ARG_ENABLE(IMAP,
+ [ --disable-IMAP don't compile in IMAP protocol support],
+ [with_IMAP=$enableval],
+ [with_IMAP=yes])
+test "$with_IMAP" = "yes" && AC_DEFINE(IMAP_ENABLE)
+
+### use option --disable-ETRN to omit the ETRN support
+AC_ARG_ENABLE(ETRN,
+ [ --disable-ETRN don't compile in ETRN protocol support],
+ [with_ETRN=$enableval],
+ [with_ETRN=yes])
+test "$with_ETRN" = "yes" && AC_DEFINE(ETRN_ENABLE)
+
### use option --enable-RPA to compile in the RPA support
AC_ARG_ENABLE(RPA,
[ --enable-RPA compile in RPA protocol support],