aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-12-30 18:27:14 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-12-30 18:27:14 +0000
commit28b12aba4ad1b56c1acfea4e20c1a81b91221d45 (patch)
treea9f7706d3dc84c6157ec5226e9a9d4306fcc36e1 /configure.in
parentff4d046f39e3ed641bc5d9925f61d48010c56bfb (diff)
downloadfetchmail-28b12aba4ad1b56c1acfea4e20c1a81b91221d45.tar.gz
fetchmail-28b12aba4ad1b56c1acfea4e20c1a81b91221d45.tar.bz2
fetchmail-28b12aba4ad1b56c1acfea4e20c1a81b91221d45.zip
Dave Bodenstab's error changes.
svn path=/trunk/; revision=705
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d988c620..6dea56c5 100644
--- a/configure.in
+++ b/configure.in
@@ -70,6 +70,22 @@ then
LIBS="$LIBS -lkrb -ldes"
fi
+dnl Configure command line options
+opt_enable_stdio=unset
+
+AC_ARG_ENABLE(stdio, --enable-stdio enable stdio for socket I/O, opt_enable_stdio=$enableval)
+
+if test $opt_enable_stdio = unset; then
+ dnl Set USE_STDIO based on $host
+ case $host in
+ *-*-*freebsd*)
+ AC_DEFINE(USE_STDIO)
+ ;;
+ esac
+elif test $opt_enable_stdio = yes; then
+ AC_DEFINE(USE_STDIO)
+fi
+
dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
@@ -77,7 +93,7 @@ AC_SUBST(EXTRASRC)
AC_SUBST(EXTRAOBJ)
AC_CHECK_FUNCS(tcsetattr stty setsid seteuid gethostbyname res_search herror \
- strrchr strerror setlinebuf)
+ strrchr strerror setlinebuf syslog snprintf vsnprintf)
dnl AC_FUNC_SETVBUF_REVERSED