aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-01-31 00:19:45 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-01-31 00:19:45 +0000
commit2536f3bbf0c7d5fc3ef14a21c11e07efea6cf294 (patch)
tree3f86d382fdd1589334dbfd68b74b870d932906ca /configure.in
parentfb97c4e25a3fc602c050d8e0b52b84d6b01ebefc (diff)
downloadfetchmail-2536f3bbf0c7d5fc3ef14a21c11e07efea6cf294.tar.gz
fetchmail-2536f3bbf0c7d5fc3ef14a21c11e07efea6cf294.tar.bz2
fetchmail-2536f3bbf0c7d5fc3ef14a21c11e07efea6cf294.zip
Autoconfigure detection of whether we have 2.2.
svn path=/trunk/; revision=2358
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 56098371..d637ddd1 100644
--- a/configure.in
+++ b/configure.in
@@ -183,6 +183,17 @@ AC_TRY_LINK([#include <signal.h>
[AC_DEFINE(SYS_SIGLIST_DECLARED) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
+dnl Figure out whether we're using a 2.2 kernel (assuming this is Linux)
+AC_MSG_CHECKING(OS kernel major version)
+set -- `uname -r | tr '.' ' '`
+release="${1}.${2}"
+AC_MSG_RESULT($release)
+if expr "$release" '>=' '2.2' >/dev/null
+then
+ AC_DEFINE(HAVE_NEWPROCNETDEV)
+ AC_MSG_RESULT("assuming new /proc/dev/net format")
+fi
+
# Find the right directory to put the root-mode PID file in
for dir in "/var/run" "/etc"
do