aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-09-21 04:12:24 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-09-21 04:12:24 +0000
commit186a0309738d7658bb305b913ca5552fd1af1fce (patch)
treeebc761d5588526427ea3fd6d083909486996438a /configure.in
parent314dc7dc3df37efa35058d8c1e3dd22dbbb2ed43 (diff)
downloadfetchmail-186a0309738d7658bb305b913ca5552fd1af1fce.tar.gz
fetchmail-186a0309738d7658bb305b913ca5552fd1af1fce.tar.bz2
fetchmail-186a0309738d7658bb305b913ca5552fd1af1fce.zip
Separate optimization from Kerberos flags.
svn path=/trunk/; revision=1382
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e8908274..9bdafd25 100644
--- a/configure.in
+++ b/configure.in
@@ -29,6 +29,8 @@ AC_C_CONST dnl getopt needs this.
AC_PROG_LEX
AC_PROG_YACC
+AC_SUBST(CEFLAGS)
+AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
# Under sysV68, socket and friends are provided by the C library.
@@ -169,16 +171,16 @@ AC_ARG_WITH(kerberos,
# configuring the BSD/OS Kerberos IV support, though.
if test -n "$with_kerberos"
then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I$with_kerberos"
- LDFLAGS="$LDFLAGS -L$dir/lib"
+ CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I$with_kerberos"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
LIBS="$LIBS -lkrb -ldes"
else
for dir in /usr/kerberos /usr/kerberosIV /usr/athena
do
if test -f "$dir/include/krb.h"
then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I$dir/include"
- LDFLAGS="$LDFLAGS -L$dir/lib"
+ CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I$dir/include"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
LIBS="$LIBS -lkrb -ldes"
break
fi