aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-01-05 18:33:40 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-01-05 18:33:40 +0000
commit13d952ccc75721d9396dfea9484eaf203c764c4f (patch)
treee4d2f82531ad35b7eb99bb2e714e0d65261139ea /configure.in
parent12d0ef921c8276833cafc30c31462e265233390e (diff)
downloadfetchmail-13d952ccc75721d9396dfea9484eaf203c764c4f.tar.gz
fetchmail-13d952ccc75721d9396dfea9484eaf203c764c4f.tar.bz2
fetchmail-13d952ccc75721d9396dfea9484eaf203c764c4f.zip
Make --with-gettext work.
svn path=/trunk/; revision=3006
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 73edf920..e032194c 100644
--- a/configure.in
+++ b/configure.in
@@ -85,10 +85,15 @@ AC_CHECK_FUNC(socket,
AC_CHECK_LIB(socket,socket)
AC_CHECK_LIB(inet,socket))
-# If gettext isn't in the C library, maybe there's a -lintl.
-AC_CHECK_FUNC(gettext,
- AC_MSG_RESULT(using libc's gettext),
- AC_CHECK_LIB(intl,gettext))
+# If gettext isn't in the C library, maybe there's a -lintl. However,
+# do not check if user has specified --with-included-gettext. On
+# some systems (e.g. Solaris), there is a gettext in libc which
+# we do not want to use if --with-included-gettext is specified.
+if test x$nls_cv_force_use_gnu_gettext != xyes; then
+ AC_CHECK_FUNC(gettext,
+ AC_MSG_RESULT(using libc's gettext),
+ AC_CHECK_LIB(intl,gettext))
+fi
# The condition in this test copes with the presence of inet_addr in libc6.
AC_CHECK_FUNC(inet_addr,