aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-01-05 21:38:45 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-01-05 21:38:45 +0000
commit120896f095d82334fc3de14d046c7bffca3046b2 (patch)
tree91b5773d27a3f8a2c5223741286a2812e55d2b81 /configure.in
parent5658140be488659ae02c74e3a5cf9752ca85c770 (diff)
downloadfetchmail-120896f095d82334fc3de14d046c7bffca3046b2.tar.gz
fetchmail-120896f095d82334fc3de14d046c7bffca3046b2.tar.bz2
fetchmail-120896f095d82334fc3de14d046c7bffca3046b2.zip
Reorganization.
svn path=/trunk/; revision=3016
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in128
1 files changed, 65 insertions, 63 deletions
diff --git a/configure.in b/configure.in
index 223beee5..a50d5947 100644
--- a/configure.in
+++ b/configure.in
@@ -335,12 +335,13 @@ AC_ARG_WITH(kerberos5,
[ --with-kerberos5=DIR point fetchmail compilation at a Kerberos 5 directory])
# The "then" arm (nonempty $with_kerberos5) is kind of a crock. It works for
-# configuring the BSD/OS Kerberos IV support, though.
+# configuring the BSD/OS Kerberos V support, though.
if test -n "$with_kerberos5" -a "$with_kerberos5" != "no"
then
# Path given
- CEFLAGS="$CEFLAGS -I$with_kerberos5/include"
+ echo "Configuring kerberosIV for `uname`"
AC_DEFINE(KERBEROS_V5)
+ CEFLAGS="$CEFLAGS -I$with_kerberos5/include"
LDEFLAGS="$LDEFLAGS -L$with_kerberos5/lib"
if test -f "$with_kerberos5/include/roken.h"
then
@@ -370,6 +371,68 @@ elif test "$with_kerberos" != "no" -a "$with_kerberos5" != "no" ; then
done
fi
+### use option --with-kerberos=DIR to point at a Kerberos IV directory
+AC_ARG_WITH(kerberos,
+ [ --with-kerberos=DIR point fetchmail compilation at a Kerberos IV directory])
+
+# The "elif" arm (nonempty $with_kerberos) is kind of a crock. It works for
+# configuring the BSD/OS Kerberos IV support, though.
+
+# Check for a NetBSD/OpenBSD special case
+if test "$with_kerberos" = "yes" && test `uname` = "NetBSD" -o `uname` = "OpenBSD"
+then
+ # Path given
+ echo "Configuring kerberosIV for `uname`"
+ AC_DEFINE(KERBEROS_V4)
+ CEFLAGS="$CEFLAGS -I/usr/include/kerberosIV"
+ LIBS="$LIBS -lkrb -ldes"
+elif test -n "$with_kerberos" -a -n "$with_kerberos5" -a "$with_kerberos" != "no" -a "$with_kerberos5" != "no"
+then
+ AC_DEFINE(KERBEROS_V4)
+ CEFLAGS="$CEFLAGS -I$with_kerberos/include"
+ LDEFLAGS="$LDEFLAGS -L$with_kerberos/lib"
+ if test -f "$with_kerberos5/roken.h"
+ then
+ AC_DEFINE(HEIMDAL)
+ LIBS="-lkrb4 -l45 $LIBS"
+ else
+ LIBS="-lkrb4 -ldes425 $LIBS"
+ fi
+elif test -n "$with_kerberos5" -a "$with_kerberos" != "no" -a "$with_kerberos5" != "no"
+then
+ for dir in /usr/kerberos /usr/kerberosIV /usr/athena
+ do
+ if test -f "$dir/include/kerberosIV/krb.h"
+ then
+ AC_DEFINE(KERBEROS_V4)
+ CEFLAGS="$CEFLAGS -I$dir/include"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
+ LIBS="-lkrb4 -ldes425 $LIBS"
+ break
+ fi
+ done
+elif test -n "$with_kerberos" -a "$with_kerberos" != "no"
+then
+ AC_DEFINE(KERBEROS_V4)
+ CEFLAGS="$CEFLAGS -I$with_kerberos/include"
+ LDEFLAGS="$LDEFLAGS -L$with_kerberos/lib"
+ LIBS="$LIBS -lkrb -ldes"
+else
+ if test "$with_kerberos" != "no"
+ then
+ AC_DEFINE(KERBEROS_V4)
+ for dir in /usr/kerberos /usr/kerberosIV /usr/athena
+ do
+ if test -f "$dir/include/krb.h"
+ then
+ CEFLAGS="$CEFLAGS -I$dir/include"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
+ LIBS="$LIBS -lkrb -ldes"
+ break
+ fi
+ done
+fi
+
### use option --with-ssl to compile in the SSL support
AC_ARG_WITH(ssl,
[ --with-ssl=[DIR] enable SSL support using libraries in DIR],
@@ -431,67 +494,6 @@ else
echo 'Disabling SSL support...'
fi
-### use option --with-kerberos=DIR to point at a Kerberos directory
-AC_ARG_WITH(kerberos,
- [ --with-kerberos=DIR point fetchmail compilation at a Kerberos directory])
-
-# The "elif" arm (nonempty $with_kerberos) is kind of a crock. It works for
-# configuring the BSD/OS Kerberos IV support, though.
-
-# Check for a NetBSD/OpenBSD special case
-if test "$with_kerberos" = "yes" && test `uname` = "NetBSD" -o `uname` = "OpenBSD"
-then
- echo "Configuring kerberosIV for `uname`"
- AC_DEFINE(KERBEROS_V4)
- CEFLAGS="$CEFLAGS -I/usr/include/kerberosIV"
- LIBS="$LIBS -lkrb -ldes"
-elif test -n "$with_kerberos" -a -n "$with_kerberos5" -a "$with_kerberos" != "no" -a "$with_kerberos5" != "no"
-then
- AC_DEFINE(KERBEROS_V4)
- CEFLAGS="$CEFLAGS -I$with_kerberos/include"
- LDEFLAGS="$LDEFLAGS -L$with_kerberos/lib"
- if test -f "$with_kerberos5/roken.h"
- then
- AC_DEFINE(HEIMDAL)
- LIBS="-lkrb4 -l45 $LIBS"
- else
- LIBS="-lkrb4 -ldes425 $LIBS"
- fi
-elif test -n "$with_kerberos5" -a "$with_kerberos" != "no" -a "$with_kerberos5" != "no"
-then
- for dir in /usr/kerberos /usr/kerberosIV /usr/athena
- do
- if test -f "$dir/include/kerberosIV/krb.h"
- then
- AC_DEFINE(KERBEROS_V4)
- CEFLAGS="$CEFLAGS -I$dir/include"
- LDEFLAGS="$LDEFLAGS -L$dir/lib"
- LIBS="-lkrb4 -ldes425 $LIBS"
- break
- fi
- done
-elif test -n "$with_kerberos" -a "$with_kerberos" != "no"
-then
- AC_DEFINE(KERBEROS_V4)
- CEFLAGS="$CEFLAGS -I$with_kerberos/include"
- LDEFLAGS="$LDEFLAGS -L$with_kerberos/lib"
- LIBS="$LIBS -lkrb -ldes"
-else
- if test "$with_kerberos" != "no"
- then
- AC_DEFINE(KERBEROS_V4)
- for dir in /usr/kerberos /usr/kerberosIV /usr/athena
- do
- if test -f "$dir/include/krb.h"
- then
- CEFLAGS="$CEFLAGS -I$dir/include"
- LDEFLAGS="$LDEFLAGS -L$dir/lib"
- LIBS="$LIBS -lkrb -ldes"
- break
- fi
- done
-fi
-
### use option --with-socks=DIR to point at SOCKS library
AC_ARG_WITH(socks,
[ --with-socks[=DIR] add built-in SOCKS firewall access],