aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2019-08-25 18:52:53 +0200
committerMatthias Andree <matthias.andree@gmx.de>2019-08-25 18:52:53 +0200
commite0e7a74bde52a1aa02d1da758128722598fb6dd8 (patch)
tree3064dd064dcde0969467c6d2e068d8ccbbd648b1 /configure.ac
parent5256f6122e9843b1e9988a742ed6c2a4923bc2bd (diff)
downloadfetchmail-e0e7a74bde52a1aa02d1da758128722598fb6dd8.tar.gz
fetchmail-e0e7a74bde52a1aa02d1da758128722598fb6dd8.tar.bz2
fetchmail-e0e7a74bde52a1aa02d1da758128722598fb6dd8.zip
Align with legacy_6x.
* Normalize include order. * Backport missed bug fixes. * Remove dead code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 35 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 47d88712..223ac149 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,7 +375,8 @@ AM_CONDITIONAL(POP2_ENABLE, test "$with_POP2" = yes)
### use option --disable-POP3 to omit the POP3 support
AC_ARG_ENABLE(POP3,
- [ --disable-POP3 don't compile in POP3 protocol support],
+ [AS_HELP_STRING([--disable-POP3],
+ [do not compile in POP3 protocol support])],
[with_POP3=$enableval],
[with_POP3=yes])
test "$with_POP3" = "yes" && AC_DEFINE(POP3_ENABLE,1,Define if you want POP3 support compiled in)
@@ -383,7 +384,8 @@ AM_CONDITIONAL(POP3_ENABLE, test "$with_POP3" = yes)
### use option --disable-IMAP to omit the IMAP support
AC_ARG_ENABLE(IMAP,
- [ --disable-IMAP don't compile in IMAP protocol support],
+ [AS_HELP_STRING([--disable-IMAP],
+ [do not compile in IMAP protocol support])],
[with_IMAP=$enableval],
[with_IMAP=yes])
test "$with_IMAP" = "yes" && AC_DEFINE(IMAP_ENABLE,1,Define if you want IMAP support compiled in)
@@ -391,7 +393,8 @@ AM_CONDITIONAL(IMAP_ENABLE, test "$with_IMAP" = yes)
### use option --disable-ETRN to omit the ETRN support
AC_ARG_ENABLE(ETRN,
- [ --disable-ETRN don't compile in ETRN protocol support],
+ [AS_HELP_STRING([--disable-ETRN],[do not compile in ETRN protocol
+ support])],
[with_ETRN=$enableval],
[with_ETRN=yes])
test "$with_ETRN" = "yes" && AC_DEFINE(ETRN_ENABLE,1,Define if you want ETRN support compiled in.)
@@ -399,7 +402,8 @@ AM_CONDITIONAL(ETRN_ENABLE, test "$with_ETRN" = yes)
### use option --disable-ODMR to omit the ODMR support
AC_ARG_ENABLE(ODMR,
- [ --disable-ODMR don't compile in ODMR protocol support],
+ [AS_HELP_STRING([--disable-ODMR],[do not compile in ODMR protocol
+ support])],
[with_ODMR=$enableval],
[with_ODMR=yes])
test "$with_ODMR" = "yes" && AC_DEFINE(ODMR_ENABLE,1,Define if you want ODMR support compiled in)
@@ -407,7 +411,8 @@ AM_CONDITIONAL(ODMR_ENABLE, test "$with_ODMR" = yes)
### use option --enable-RPA to compile in the RPA support
AC_ARG_ENABLE(RPA,
- [ --enable-RPA compile in RPA protocol support],
+ [AS_HELP_STRING([--enable-RPA],[compile in RPA protocol
+ support])],
[with_RPA=$enableval],
[with_RPA=no])
test "$with_RPA" = "yes" && AC_DEFINE(RPA_ENABLE,1,Define if you want RPA support compiled in)
@@ -415,7 +420,8 @@ AM_CONDITIONAL(RPA_ENABLE, test "$with_RPA" = yes)
### use option --enable-NTLM to compile in the NTLM support
AC_ARG_ENABLE(NTLM,
- [ --enable-NTLM compile in NTLM authentication support],
+ [AS_HELP_STRING([--enable-NTLM],[compile in NTLM authentication
+ support])],
[with_NTLM=$enableval],
[with_NTLM=no])
test "$with_NTLM" = "yes" && AC_DEFINE(NTLM_ENABLE,1,Define if you want NTLM authentication)
@@ -423,7 +429,7 @@ AM_CONDITIONAL(NTLM_ENABLE, test "$with_NTLM" = yes)
### use option --enable-SDPS to compile in the SDPS support
AC_ARG_ENABLE(SDPS,
- [ --enable-SDPS compile in SDPS protocol support],
+ [AS_HELP_STRING([--enable-SDPS],[compile in SDPS protocol support])],
[with_SDPS=$enableval],
[with_SDPS=no])
if test "$with_SDPS" = yes ; then
@@ -443,7 +449,8 @@ AC_CACHE_SAVE
### use option --enable-opie to compile in the OPIE support
AC_ARG_ENABLE(opie,
- [ --enable-opie support OTP through the OPIE library],
+ [AS_HELP_STRING([--enable-opie],[support one-time passwords
+ (OTP) through the OPIE library])],
[ AC_CHECK_HEADER(opie.h,, [AC_MSG_ERROR([cannot find <opie.h>, which is required for OPIE support.])])
AC_CHECK_LIB(opie,opiegenerator,, [AC_MSG_ERROR([cannot find libopie, which is required for OPIE support.])])
with_opie=$enableval],
@@ -501,10 +508,10 @@ if test "$fm_cv_getaddrinfo" = yes ; then
gai_ts=no
dnl we have getaddrinfo() - check if the OS is known to have a async-signal-safe implementation
case $host_os in
- darwin9*) gai_ts=yes ;;
- linux*) gai_ts=yes ;;
- freebsd5.5|freebsd6*|freebsd7*) gai_ts=yes ;;
- solaris2.8|solaris2.9|solaris2.10) gai_ts=yes ;;
+ darwin*) gai_ts=yes ;;
+ linux*) gai_ts=yes ;;
+ freebsd*) gai_ts=yes ;;
+ solaris*) gai_ts=yes ;;
esac
AC_MSG_RESULT($gai_ts)
if test $gai_ts = yes ; then
@@ -523,14 +530,15 @@ fi
# * Move all the kerberos header mess to kerberos.h, and #include that
# in driver.c and kerberos.c.
#
-# Tested using the Heimdal Kerberos V libs, Kungliga Tekniska Högskolan (the
+# Tested using the Heimdal Kerberos V libs, Kungliga Tekniska Högskolan (the
# Royal Institute of Technology in Stockholm, Sweden)'s kerberos IV libs, and
# the MIT reference implementation of KerberosV (all as packaged in Debian).
### use option --with-kerberos5=DIR to point at a Kerberos 5 directory
### make sure --with-ssl is run before --with-kerberos* !
AC_ARG_WITH(kerberos5,
- [ --with-kerberos5=DIR point fetchmail compilation at a Kerberos 5 directory],
+ [AS_HELP_STRING([--with-kerberos5[[=DIR]]],[point fetchmail
+ compilation at a Kerberos 5 directory])],
[
if test "$with_kerberos5" != "no"
then
@@ -708,7 +716,9 @@ AM_CONDITIONAL(KERBEROS_V4_ENABLE, test "$KERBEROS_V4" = 1)
### use option --with-ssl to compile in the SSL support
AC_ARG_WITH(ssl,
- [ --with-ssl=[DIR] enable SSL support using libraries in DIR],
+ [AS_HELP_STRING([--with-ssl[[={yes|no|DIR}]]],[Use OpenSSL from
+ DIR/include/openssl and
+ DIR/lib (default: yes). Yes means try to find it.])],
[with_ssl=$withval],
[with_ssl=yes])
@@ -755,7 +765,7 @@ then
AC_MSG_NOTICE(Enabling OpenSSL support in $with_ssl.)
test "$with_ssl" != "/usr" && CFLAGS="$CFLAGS -I$with_ssl/include"
### In Red Hat 9, this file includes a reference to <krb5.h>, so we
- ### force the Kerberos direcory onto the include path so it will build.
+ ### force the Kerberos directory onto the include path so it will build.
CFLAGS="$CFLAGS -I/usr/kerberos/include"
### OpenBSD comes with ssl headers
else
@@ -789,13 +799,17 @@ else
fi
case "$LIBS" in *-lssl*)
+ AC_CHECK_DECLS([TLS1_2_VERSION],,
+ AC_MSG_ERROR([Your OpenSSL version is too old and does not support TLS v1.2. Upgrade.]),
+ [#include <openssl/ssl.h>])
AC_CHECK_DECLS([SSLv3_client_method],,,[#include <openssl/ssl.h>])
;;
esac
### use option --with-socks=DIR to point at SOCKS library
AC_ARG_WITH(socks,
- [ --with-socks[=DIR] add built-in SOCKS firewall access],
+ [AS_HELP_STRING([--with-socks[[=DIR]]],[add built-in SOCKS (4)
+ firewall access])],
[
if test "$with_socks" != no
then
@@ -813,7 +827,8 @@ fi])
### use option --with-socks5=DIR to point at SOCKS library
AC_ARG_WITH(socks5,
- [ --with-socks5[=DIR] add built-in SOCKS5 firewall access],
+ [AS_HELP_STRING([--with-socks5[[=DIR]]],[add built-in SOCKS5
+ firewall access])],
[
if test "$with_socks5" != no
then
@@ -836,7 +851,8 @@ AC_ma_SEARCH_PACKAGE(hesiod, hesiod_getmailhost, /usr/athena /usr /usr/local,hes
### use option --with-gssapi=DIR to compile in GSSAPI support
AC_ARG_WITH(gssapi,
- [ --with-gssapi[=DIR] compile in GSSAPI support using libraries in DIR],
+ [AS_HELP_STRING([--with-gssapi[[=DIR]]],[compile in GSSAPI
+ support using libraries in DIR])],
[
if test "$with_gssapi" != "no"
then