aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2020-08-27 19:42:00 +0200
committerMatthias Andree <matthias.andree@gmx.de>2020-08-27 19:42:00 +0200
commitc92eb3c1895f10a9a4d3229ac883071b62db3920 (patch)
treee121dd0f77c2af5b48bc9f342420d6e4d2c62f4e /configure.ac
parenta0d2160c7655eb55d26d25957e43948dc2f8eb48 (diff)
downloadfetchmail-c92eb3c1895f10a9a4d3229ac883071b62db3920.tar.gz
fetchmail-c92eb3c1895f10a9a4d3229ac883071b62db3920.tar.bz2
fetchmail-c92eb3c1895f10a9a4d3229ac883071b62db3920.zip
configure.ac: Fix regression when pkg-config does not know about OpenSSL.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4ec49388..c1138ae0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -775,7 +775,9 @@ then
PKG_CHECK_MODULES([SSL],[libssl libcrypto],[LIBS="$LIBS $SSL_LIBS"],[
AS_MESSAGE([SSL-check: pkg-config check failed, using traditional probe])
LDFLAGS="$LDFLAGS -L$with_ssl/lib"
- #LIBS="$LIBS -lssl -lcrypto" # replaced by AC_LIB_LINKFLAGS below
+ AC_LIB_LINKFLAGS([crypto])
+ AC_LIB_LINKFLAGS([ssl], [crypto])
+ LIBS="$LIBS $LIBSSL $LIBCRYPTO"
dnl check if -ldl is needed
AC_MSG_CHECKING([for additional library dependencies of SSL])
found=0