aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2021-12-05 15:48:25 +0100
committerMatthias Andree <matthias.andree@gmx.de>2021-12-05 18:56:55 +0100
commitc4419bdd2557321b268f6e105d511923b9a35936 (patch)
treea1e1353e613ac8ecbc2f80976d5f36ef9919ae12 /configure.ac
parentad96f3ef1136aa4a201a5dffceb2b005be4b7011 (diff)
downloadfetchmail-c4419bdd2557321b268f6e105d511923b9a35936.tar.gz
fetchmail-c4419bdd2557321b268f6e105d511923b9a35936.tar.bz2
fetchmail-c4419bdd2557321b268f6e105d511923b9a35936.zip
Permit LibreSSL on OpenBSD.
On OpenBSD, libressl is "normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs" according to Stuart Henderson, so according to the GNU GPL v2 clause 3, we can permit LibreSSL for OpenBSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f8e4ca84..7cacff99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -889,9 +889,15 @@ AS_MESSAGE([
LIBS: $LIBS])
case "$LIBS" in *-lssl*|*libssl*|*-lwolfssl*|*libwolfssl*)
- AC_CHECK_DECLS([LIBRESSL_VERSION_NUMBER],
+ case $host_os in
+ openbsd*) ;; dnl OpenBSD ships LibreSSL in the base operating system
+ dnl so makes use of the GPL2 clause 3 exception.
+ *)
+ AC_CHECK_DECLS([LIBRESSL_VERSION_NUMBER],
AC_MSG_ERROR([fetchmail cannot legally be linked against LibreSSL for lack of GPL2 clause 2b exception. See COPYING.]),,
[#include <openssl/ssl.h>])
+ ;;
+ esac
AC_CHECK_DECLS([TLS1_3_VERSION],,
AC_MSG_WARN([Your OpenSSL version is too old and does not support TLS v1.3. Upgrade.]),
[#include <openssl/ssl.h>])