aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2020-01-04 00:47:17 +0100
committerMatthias Andree <matthias.andree@gmx.de>2020-01-04 00:47:17 +0100
commitc2d2c44713365211990fded2b0b22c0d23394cb7 (patch)
tree98967a966482fd125508106c8a5149d3a0683cd3 /configure.ac
parent013493b6ea2909a2a9daadc2ef9beab16cff8c39 (diff)
downloadfetchmail-c2d2c44713365211990fded2b0b22c0d23394cb7.tar.gz
fetchmail-c2d2c44713365211990fded2b0b22c0d23394cb7.tar.bz2
fetchmail-c2d2c44713365211990fded2b0b22c0d23394cb7.zip
Add LDFLAGS=-L$with_ssl/lib when using --with-ssl.
Fixes GitLab issue #9, Compile error with OpenSSL 1.1.1 on Debian Squeeze.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f00ba500..ea241673 100644
--- a/configure.ac
+++ b/configure.ac
@@ -763,7 +763,7 @@ then
then
### ssl.h found under openssl. Use openssl configuration preferentially,
AC_MSG_NOTICE(Enabling OpenSSL support in $with_ssl.)
- test "$with_ssl" != "/usr" && CFLAGS="$CFLAGS -I$with_ssl/include"
+ test "$with_ssl" != "/usr" && CFLAGS="$CFLAGS -I$with_ssl/include" LDFLAGS="$LDFLAGS -L$with_ssl/lib"
### In Red Hat 9, this file includes a reference to <krb5.h>, so we
### force the Kerberos directory onto the include path so it will build.
CFLAGS="$CFLAGS -I/usr/kerberos/include"