aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2019-05-12 19:21:23 +0200
committerMatthias Andree <matthias.andree@gmx.de>2019-05-12 19:21:23 +0200
commitb53d832f42738b2a680f4ed05bb56e8f1d1f2abb (patch)
tree8d1b84c4d8290bf2d5c54682a5a309727b996604 /configure.ac
parent6b62bbd92c18d3259eb329e2a94a09aef6421588 (diff)
parent4ada29fdac86d0b2b90f770a61c714610b45ffab (diff)
downloadfetchmail-b53d832f42738b2a680f4ed05bb56e8f1d1f2abb.tar.gz
fetchmail-b53d832f42738b2a680f4ed05bb56e8f1d1f2abb.tar.bz2
fetchmail-b53d832f42738b2a680f4ed05bb56e8f1d1f2abb.zip
Merge branch 'ffontaine/fetchmail-legacy_64' into legacy_64
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 21 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 408ca89a..59a90392 100644
--- a/configure.ac
+++ b/configure.ac
@@ -777,25 +777,28 @@ then
else
AC_MSG_ERROR([SSL support enabled, but OpenSSL not found])
fi
- LDFLAGS="$LDFLAGS -L$with_ssl/lib"
- LIBS="$LIBS -lssl -lcrypto"
- dnl check if -ldl is needed
- AC_MSG_CHECKING([for additional library dependencies of SSL])
- found=0
- save_LIBS="$LIBS"
- for i in "" "-ldl" ; do
- LIBS="$LDFLAGS $save_LIBS $i"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <openssl/ssl.h>],[SSL_connect((SSL *)0)])],[found=1; break])
- done
- if test $found = 0 ; then
- AC_MSG_RESULT([error])
- AC_MSG_ERROR([cannot link with SSL - check config.log])
- fi
- LIBS="$save_LIBS $i"
- if test "$i" = "" ; then i="(none)" ; fi
- AC_MSG_RESULT($i)
- dnl XXX FIXME: use pkg-config if available!
+ PKG_CHECK_MODULES([SSL],[libssl libcrypto],[LIBS="$LIBS $SSL_LIBS"],[
+ AS_MESSAGE([SSL-check: pkg-config check failed, using traditional probe])
+ LDFLAGS="$LDFLAGS -L$with_ssl/lib"
+ LIBS="$LIBS -lssl -lcrypto"
+ dnl check if -ldl is needed
+ AC_MSG_CHECKING([for additional library dependencies of SSL])
+ found=0
+ save_LIBS="$LIBS"
+ for i in "" "-ldl" ; do
+ LIBS="$LDFLAGS $save_LIBS $i"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <openssl/ssl.h>],[SSL_connect((SSL *)0)])],[found=1; break])
+ done
+ if test $found = 0 ; then
+ AC_MSG_RESULT([error])
+ AC_MSG_ERROR([cannot link with SSL - check config.log])
+ fi
+ LIBS="$save_LIBS $i"
+ if test "$i" = "" ; then i="(none)" ; fi
+ AC_MSG_RESULT($i)
+ ])
AC_DEFINE(SSL_ENABLE, 1, [Define if you want SSL support compiled in])
+ AS_MESSAGE(Enabling SSL support.)
else
AC_MSG_WARN(Disabling SSL support.)
AC_MSG_WARN(Consider re-running configure --with-ssl.)