aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2011-10-26 00:30:32 +0200
committerMatthias Andree <matthias.andree@gmx.de>2011-10-26 00:33:26 +0200
commit9f9c3cbd8d825f80e99ddfdefa530be3955bcd56 (patch)
tree0a7c36422cfed7696b28ec262a1d65071edba36a /configure.ac
parent514239e63f18708b86d41db7fa78f49714b10c29 (diff)
downloadfetchmail-9f9c3cbd8d825f80e99ddfdefa530be3955bcd56.tar.gz
fetchmail-9f9c3cbd8d825f80e99ddfdefa530be3955bcd56.tar.bz2
fetchmail-9f9c3cbd8d825f80e99ddfdefa530be3955bcd56.zip
Fix build on SSLv2-disabled OpenSSL setups
On systems where SSLv2_client_method isn't defined in OpenSSL (such as newer Debian, and Ubuntu starting with 11.10 oneiric ocelot), don't reference it (to fix the build) and print a run-time error that the OS does not support SSLv2. Fixes Debian Bug #622054, but note that that bug report has a more thorough patch that does away with SSLv2 altogether.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b66ad809..de3a37a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -799,6 +799,11 @@ else
AC_MSG_NOTICE(Disabling SSL support.)
fi
+case "$LIBS" in *-lssl*)
+ AC_CHECK_DECLS([SSLv2_client_method],,,[#include <openssl/ssl.h>])
+ ;;
+esac
+
### use option --with-socks=DIR to point at SOCKS library
AC_ARG_WITH(socks,
[ --with-socks[=DIR] add built-in SOCKS firewall access],