aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-09-25 22:35:36 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-09-25 22:35:36 +0000
commit9da662c467409420d226afbfbc648c5d6bbbacfb (patch)
tree17528782d938741ba3349c398ef54725616e6560 /configure.ac
parente2dfd9bb1b9813e17b17f9b7885fb604cf53ee69 (diff)
downloadfetchmail-9da662c467409420d226afbfbc648c5d6bbbacfb.tar.gz
fetchmail-9da662c467409420d226afbfbc648c5d6bbbacfb.tar.bz2
fetchmail-9da662c467409420d226afbfbc648c5d6bbbacfb.zip
Revise SSL dependency check: use LDFLAGS (to get -L options), detect error.
svn path=/trunk/; revision=4335
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 58e0bc53..5ade7178 100644
--- a/configure.ac
+++ b/configure.ac
@@ -600,13 +600,19 @@ then
fi
LDEFLAGS="$LDEFLAGS -L$with_ssl/lib"
LIBS="$LIBS -lssl -lcrypto"
- dnl check if -ldl is needed!
+ dnl check if -ldl is needed
AC_MSG_CHECKING([for additional library dependencies of SSL])
+ found=0
+ save_LIBS="$LIBS"
for i in "" "-ldl" ; do
- save_LIBS="$LIBS"
- LIBS="$LIBS $i"
- AC_LINK_IFELSE([AC_LANG_PROGRAM(,[SSL_library_init()])],break,LIBS="$save_LIBS")
+ LIBS="$LDEFLAGS $save_LIBS $i"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(,[SSL_library_init()])],[found=1; break])
done
+ if test $found = 0 ; then
+ AC_MSG_RESULT([error])
+ AC_MSG_ERROR([cannot link with SSL - check config.log])
+ fi
+ LIBS="$save_LIBS $i"
if test "$i" = "" ; then i="(none)" ; fi
AC_MSG_RESULT($i)
dnl XXX FIXME: use pkg-config if available!