aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-09-21 22:00:28 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-09-21 22:00:28 +0000
commit9577c4f844d9f6e8e3f33502882ca2b342985130 (patch)
treef78671ea50d629f7fbaf3e79859f727d9b0bc4ec /configure.ac
parenta5180c9109b918cf441ffd0c90e05ab8c35d40d9 (diff)
downloadfetchmail-9577c4f844d9f6e8e3f33502882ca2b342985130.tar.gz
fetchmail-9577c4f844d9f6e8e3f33502882ca2b342985130.tar.bz2
fetchmail-9577c4f844d9f6e8e3f33502882ca2b342985130.zip
Kerberos IV detection fix for FreeBSD 4. Simon Barner.
svn path=/trunk/; revision=4315
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 06426108..3d3ee540 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
dnl
-AC_INIT([fetchmail],[6.2.9-rc4])
+AC_INIT([fetchmail],[6.2.9-rc5])
AC_CONFIG_SRCDIR([fetchmail.h])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_LIBOBJ_DIR([.])
@@ -507,7 +507,11 @@ else
AC_CHECK_LIB(45, krb_mk_req)
fi
LDFLAGS="-L$dir/lib $ac_saveLDFLAGS"
- AC_SEARCH_LIBS(des_string_to_key, [des425 des crypto], [], continue)
+ if test `uname` = "FreeBSD"; then
+ AC_SEARCH_LIBS(_ossl_old_des_string_to_key, [des425 des crypto], [], continue)
+ else
+ AC_SEARCH_LIBS(des_string_to_key, [crypto], [], continue)
+ fi
AC_SEARCH_LIBS(krb_realmofhost, [krb4 krb], [], continue)
with_kerberos="$dir"
if test -f "$dir/include/kerberosIV/krb.h" ; then