aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2012-08-15 23:41:03 +0200
committerMatthias Andree <matthias.andree@gmx.de>2012-08-15 23:41:03 +0200
commit91b6ab63f35f8f11544b401fced7859d963ad06c (patch)
tree90b7dba76e665983c226e3c987c1e46e368ed89a /configure.ac
parent0f4692d4340712874b66f37228ce73c93ec75aac (diff)
downloadfetchmail-91b6ab63f35f8f11544b401fced7859d963ad06c.tar.gz
fetchmail-91b6ab63f35f8f11544b401fced7859d963ad06c.tar.bz2
fetchmail-91b6ab63f35f8f11544b401fced7859d963ad06c.zip
GSSAPI build fix.
The GSSAPI-related autoconf code now matches gssapi.c better, and uses a different check to look for GSS_C_NT_HOSTBASED_SERVICE. This fixes the GSSAPI-enabled build on NetBSD 6 Beta.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 39a2e025..5bc25fb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -898,11 +898,20 @@ then
CPPFLAGS="$CPPFLAGS -I$with_gssapi/include"
fi
AC_CHECK_HEADERS(gss.h gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
- if test "$ac_cv_header_gssapi_h" = "yes"; then
- AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE,1,Define if you have MIT kerberos))
- else
- AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi/gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
- fi
+ AC_CHECK_DECLS(GSS_C_NT_HOSTBASED_SERVICE,,,[
+ AC_INCLUDES_DEFAULT
+ #if HAVE_GSS_H
+ #include <gss.h>
+ #endif
+ #if HAVE_GSSAPI_GSSAPI_H
+ #include <gssapi/gssapi.h>
+ #elif HAVE_GSSAPI_H
+ #include <gssapi.h>
+ #endif
+ #if HAVE_GSSAPI_GSSAPI_GENERIC_H
+ #include <gssapi/gssapi_generic.h>
+ #endif
+ ])
fi])
dnl ,------------------------------------------------------------------