aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2006-04-01 23:24:17 +0000
committerMatthias Andree <matthias.andree@gmx.de>2006-04-01 23:24:17 +0000
commit884266c5f0f1d53c15fa2e9d98132c0749c576ff (patch)
tree9467b8a5c5a83f2f92b516b05ea1ab959207fd3b /configure.ac
parentc324c5795176ace49f364980e4a9fa0ece31b030 (diff)
downloadfetchmail-884266c5f0f1d53c15fa2e9d98132c0749c576ff.tar.gz
fetchmail-884266c5f0f1d53c15fa2e9d98132c0749c576ff.tar.bz2
fetchmail-884266c5f0f1d53c15fa2e9d98132c0749c576ff.zip
Fix old_LIBS name when checking for -lresolv, to avoid losing former $LIBS
contents. Fixes compile failures on Solaris. (Matthias Andree) Restore $LIBS when res_search has not been found. (Miloslav Trmac) svn path=/branches/BRANCH_6-3/; revision=4769
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 72ff3df5..5fb79935 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,7 +147,7 @@ AC_CHECK_DECLS(strerror)
# and breaks gethostbyname(2). It's better to use the bind stuff in the C
# library. So don't add -lresolv to the link list unless it's necessary
# (It will be necessary when using GNU libc6).
-old_libs=$LIBS
+old_LIBS="$LIBS"
for lib in '' -lresolv; do
if test -z "$lib"; then
AC_MSG_CHECKING([for res_search in libc])
@@ -170,8 +170,9 @@ extern int res_search();
]], [[res_search(0, 0, 0, 0, 0);]])],
[AC_MSG_RESULT([found])
AC_DEFINE(HAVE_RES_SEARCH, [1],
- [Define to 1 if you have the `res_search' function.])
+ [Define to 1 if you have the 'res_search' function.])
break], [AC_MSG_RESULT([not found])])
+ LIBS=$old_LIBS
done
dnl Check for libcrypt -- it may live in libc or libcrypt, as on IRIX