aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2019-05-12 19:20:58 +0200
committerMatthias Andree <matthias.andree@gmx.de>2019-05-12 19:20:58 +0200
commit4ada29fdac86d0b2b90f770a61c714610b45ffab (patch)
tree8d1b84c4d8290bf2d5c54682a5a309727b996604 /configure.ac
parentbcab21a977732e2fe24f37cb394f913af0d8b166 (diff)
downloadfetchmail-4ada29fdac86d0b2b90f770a61c714610b45ffab.tar.gz
fetchmail-4ada29fdac86d0b2b90f770a61c714610b45ffab.tar.bz2
fetchmail-4ada29fdac86d0b2b90f770a61c714610b45ffab.zip
Be a bit more verbose about SSL probing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 59a5048c..59a90392 100644
--- a/configure.ac
+++ b/configure.ac
@@ -778,6 +778,7 @@ then
AC_MSG_ERROR([SSL support enabled, but OpenSSL not found])
fi
PKG_CHECK_MODULES([SSL],[libssl libcrypto],[LIBS="$LIBS $SSL_LIBS"],[
+ AS_MESSAGE([SSL-check: pkg-config check failed, using traditional probe])
LDFLAGS="$LDFLAGS -L$with_ssl/lib"
LIBS="$LIBS -lssl -lcrypto"
dnl check if -ldl is needed
@@ -797,6 +798,7 @@ then
AC_MSG_RESULT($i)
])
AC_DEFINE(SSL_ENABLE, 1, [Define if you want SSL support compiled in])
+ AS_MESSAGE(Enabling SSL support.)
else
AC_MSG_WARN(Disabling SSL support.)
AC_MSG_WARN(Consider re-running configure --with-ssl.)