aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2016-01-30 13:20:03 +0100
committerMatthias Andree <matthias.andree@gmx.de>2016-01-30 13:20:03 +0100
commit339667c1a56fa4a0ab0427c7cccaf067e4c38b0e (patch)
treeb47dcbded9b30c7e9206c989a5972f789d040d92 /configure.ac
parent415010e344c0d9ff2aabaf0006903079dcad1af6 (diff)
downloadfetchmail-339667c1a56fa4a0ab0427c7cccaf067e4c38b0e.tar.gz
fetchmail-339667c1a56fa4a0ab0427c7cccaf067e4c38b0e.tar.bz2
fetchmail-339667c1a56fa4a0ab0427c7cccaf067e4c38b0e.zip
Flip the switch and configure OpenSSL by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 71287701..d6f96c2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,8 +725,7 @@ AM_CONDITIONAL(KERBEROS_V4_ENABLE, test "$KERBEROS_V4" = 1)
AC_ARG_WITH(ssl,
[ --with-ssl=[DIR] enable SSL support using libraries in DIR],
[with_ssl=$withval],
- [with_ssl=no])
-test "$with_ssl" != "no" && AC_DEFINE(SSL_ENABLE,1,Define if you want SSL support compiled in)
+ [with_ssl=yes])
if test "$with_ssl" = "yes"
then
@@ -795,7 +794,7 @@ then
if test "$i" = "" ; then i="(none)" ; fi
AC_MSG_RESULT($i)
dnl XXX FIXME: use pkg-config if available!
- AC_DEFINE(SSL_ENABLE)
+ AC_DEFINE(SSL_ENABLE, 1, [Define if you want SSL support compiled in])
else
AC_MSG_WARN(Disabling SSL support.)
AC_MSG_WARN(Consider re-running configure --with-ssl.)