aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2010-12-14 00:41:53 +0100
committerMatthias Andree <matthias.andree@gmx.de>2010-12-14 00:41:53 +0100
commit28afa8bab125a354daf8a6114efb8df0c49767b6 (patch)
tree3ccc05659df22828fb357f5d9f0a97dfe25010b1 /configure.ac
parent6657f423a37794192659f32f1dddfd766e1f0a4f (diff)
downloadfetchmail-28afa8bab125a354daf8a6114efb8df0c49767b6.tar.gz
fetchmail-28afa8bab125a354daf8a6114efb8df0c49767b6.tar.bz2
fetchmail-28afa8bab125a354daf8a6114efb8df0c49767b6.zip
Unconditionally use our own MD5 code. Gets linked only as needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index c1d450cd..d95784f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,7 +73,7 @@ AC_TYPE_SIGNAL
AC_CHECK_HEADERS([unistd.h termios.h termio.h sgtty.h stdarg.h \
sys/itimer.h fcntl.h sys/fcntl.h memory.h sys/wait.h \
arpa/inet.h arpa/nameser.h netinet/in.h net/socket.h netdb.h \
- sys/select.h sys/socket.h sys/time.h langinfo.h md5.h])
+ sys/select.h sys/socket.h sys/time.h langinfo.h])
if test _$ac_cv_header_stdarg_h != _yes ; then
AC_MSG_WARN([stdarg.h is not defined. Unsupported configuration, proceed at your own risk.])
fi
@@ -171,16 +171,6 @@ dnl [LIBS="$LIBS -lintl"])
AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy strlcpy strlcat])
-have_md5=no
-if test "$ac_cv_header_md5_h" != no ; then
- AC_SEARCH_LIBS(MD5Init, [md], [have_md5=yes])
-fi
-
-if test "$have_md5" != yes ; then
- AC_LIBSOURCE(md5c.c)
- EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)"
-fi
-
AC_CHECK_FUNC(getopt_long, [],
[AC_LIBSOURCES([getopt.c, getopt1.c])
EXTRAOBJ="$EXTRAOBJ getopt.\$(OBJEXT) getopt1.\$(OBJEXT)"])