aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2018-06-06 01:53:04 +0200
committerMatthias Andree <matthias.andree@gmx.de>2018-06-06 02:01:12 +0200
commit1765b4b766fef54707db83a918bde9acbda79f4d (patch)
tree0059dddc0885971a86b6b937f8368356035e477c /configure.ac
parent4297a298507e9d0e056d9aff8b56cdba58c083a7 (diff)
downloadfetchmail-1765b4b766fef54707db83a918bde9acbda79f4d.tar.gz
fetchmail-1765b4b766fef54707db83a918bde9acbda79f4d.tar.bz2
fetchmail-1765b4b766fef54707db83a918bde9acbda79f4d.zip
Make compatible with a pure OpenSSL 1.1.0 API, ...
...when deprecated functions are disabled, for instance, through -DOPENSSL_API_COMPAT=0x10100000L.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0bbb30ad..ebfd7554 100644
--- a/configure.ac
+++ b/configure.ac
@@ -786,7 +786,7 @@ then
save_LIBS="$LIBS"
for i in "" "-ldl" ; do
LIBS="$LDFLAGS $save_LIBS $i"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <openssl/ssl.h>],[SSL_library_init()])],[found=1; break])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <openssl/ssl.h>],[SSL_connect((SSL *)0)])],[found=1; break])
done
if test $found = 0 ; then
AC_MSG_RESULT([error])