aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2021-11-20 19:23:57 +0100
committerMatthias Andree <matthias.andree@gmx.de>2021-11-21 00:37:08 +0100
commit12e9056cc0db29fdc1cfd79c6e08bc53ab4ab0af (patch)
tree895954e1a4208fb8aab6c18db4d89def239aa386 /configure.ac
parentf3d5722682201383f6c3d23dd9c8b51a47f90b01 (diff)
downloadfetchmail-12e9056cc0db29fdc1cfd79c6e08bc53ab4ab0af.tar.gz
fetchmail-12e9056cc0db29fdc1cfd79c6e08bc53ab4ab0af.tar.bz2
fetchmail-12e9056cc0db29fdc1cfd79c6e08bc53ab4ab0af.zip
wolfSSL: support WOLFSSL_TRUST_FILE as default trust store
...because wolfSSL 5.0.0 does not support a default trust store, unlike OpenSSL.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14d8c8ab..533bb05c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -760,6 +760,11 @@ if test "$with_wolfssl" != "no" ; then
AC_DEFINE(SSL_ENABLE, 1)
AS_MESSAGE(Enabling SSL support through wolfSSL.)
with_ssl=yes
+ if test -z "$WOLFSSL_TRUST_FILE" ; then
+ AC_MSG_ERROR([You must define WOLFSSL_TRUST_FILE and point it to the default CA certificate file (PEM format)])
+ fi
+ AC_DEFINE_UNQUOTED(WOLFSSL_TRUST_FILE, "$WOLFSSL_TRUST_FILE",
+ [Set to the default file of trusted certificates.])
else
### use option --with-ssl to compile in the SSL support