aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2020-05-04 03:04:59 +0200
committerMatthias Andree <matthias.andree@gmx.de>2020-05-04 03:04:59 +0200
commit11ba27271f8e085b06c79b732cf92f88e492f487 (patch)
tree01e60e8b46051143ee60b8cc34fce507a4078f08 /configure.ac
parentfaaeaa43e1978fe3d24d7289487021664397cdbe (diff)
downloadfetchmail-11ba27271f8e085b06c79b732cf92f88e492f487.tar.gz
fetchmail-11ba27271f8e085b06c79b732cf92f88e492f487.tar.bz2
fetchmail-11ba27271f8e085b06c79b732cf92f88e492f487.zip
Add fm_realpath(): a malloc()ating realpath() wrapper.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2cde1ba4..6fd2caf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,13 +3,13 @@ dnl Autoconfigure input file for fetchmail
# Fetchmail automatic configuration support
#
# Eric S. Raymond <esr@thyrsus.com>
-# 2004 - 2019 Matthias Andree <matthias.andree@gmx.de>
+# 2004 - 2020 Matthias Andree <matthias.andree@gmx.de>
#
dnl Process this file with autoconf to produce a configure script.
dnl
dnl XXX - if bumping version here, check fetchmail.man, too!
-AC_INIT([fetchmail],[6.4.4],[fetchmail-users@lists.sourceforge.net])
+AC_INIT([fetchmail],[6.4.5-rc1],[fetchmail-users@lists.sourceforge.net])
AC_CONFIG_SRCDIR([fetchmail.h])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_LIBOBJ_DIR([.])
@@ -98,6 +98,9 @@ AC_CHECK_DECLS([h_errno],,,[
AC_C_CONST dnl getopt needs this.
AC_C_INLINE dnl uid_db.? need this.
+AC_C_RESTRICT dnl fm_realpath needs this.
+AC_C_VOLATILE dnl check for ANSI volatile
+
AM_PROG_LEX
AC_PROG_MAKE_SET
@@ -181,6 +184,7 @@ AC_CHECK_FUNCS(tcsetattr stty setsid geteuid seteuid dnl
sigaction strdup setlocale)
AC_CHECK_DECLS([strerror])
+AC_CHECK_DECLS([PATH_MAX],,,[#include <limits.h>])
dnl INET6 is used by KAME/getnameinfo
AC_CACHE_CHECK(for AF_INET6/PF_INET6,ac_cv_inet6,
AC_COMPILE_IFELSE([
@@ -235,9 +239,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[char *p;
p = (char *) xmalloc(1);
]])],[AC_DEFINE(HAVE_VOIDPOINTER,1,[Define if your C compiler allows void * as a function result]) AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)])
-dnl Check for ANSI volatile
-AC_C_VOLATILE
-
dnl Check out the wait reality. We have to assume sys/wait.h is present.
AC_CHECK_FUNCS(waitpid wait3)
AC_MSG_CHECKING(for union wait);