aboutsummaryrefslogtreecommitdiffstats
path: root/bootstrap.sh
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2004-06-19 02:39:07 +0000
committerMatthias Andree <matthias.andree@gmx.de>2004-06-19 02:39:07 +0000
commitf4f4b5ff37b19df733987670a5689e3f49de55ca (patch)
treeef8a15db67d348907cc4abc0e1701046d04fa313 /bootstrap.sh
parent7127ff22e388f29f217f125ac9ef11dd4f5a84b4 (diff)
downloadfetchmail-f4f4b5ff37b19df733987670a5689e3f49de55ca.tar.gz
fetchmail-f4f4b5ff37b19df733987670a5689e3f49de55ca.tar.bz2
fetchmail-f4f4b5ff37b19df733987670a5689e3f49de55ca.zip
This is the large automake/gettext commit.
It cleans up the whole build system and drops generated files such as intl/ and some from po/. The package version is moved to configure.in. HTML -> txt conversion is now done in html2txt.sh To bootstrap the package, read README.svn, make sure you have all prerequisite packages installed, then run ./bootstrap.sh. svn path=/trunk/; revision=3907
Diffstat (limited to 'bootstrap.sh')
-rwxr-xr-xbootstrap.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/bootstrap.sh b/bootstrap.sh
new file mode 100755
index 00000000..4503c596
--- /dev/null
+++ b/bootstrap.sh
@@ -0,0 +1,19 @@
+#! /bin/sh
+
+# bootstrap.sh - bootstrap the fetchmail build after a fresh subversion checkout
+# (C) 2004 Matthias Andree -- GNU GPL V2
+
+set -e
+# sanity checks:
+test -f fetchmail.h
+test -f fetchmail.c
+test -f Makefile.am
+rm -rf autom4te.cache
+echo
+echo "Please stand by while generating files with autoreconf, this may"
+echo "take a minute or two..."
+echo
+autoreconf -isv
+echo
+echo "You can now run ./configure and make as usual. See INSTALL for details."
+echo