aboutsummaryrefslogtreecommitdiffstats
path: root/bootstrap.sh
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2004-06-20 09:29:43 +0000
committerMatthias Andree <matthias.andree@gmx.de>2004-06-20 09:29:43 +0000
commit8bfa1889ebdbff232d567a761ea1ec8d32c18e52 (patch)
treef650f854079187afa3f5f5d3ba26c480dbeec49d /bootstrap.sh
parent85c93ddaca632144b14667e1c66aa14436d1a8f3 (diff)
downloadfetchmail-8bfa1889ebdbff232d567a761ea1ec8d32c18e52.tar.gz
fetchmail-8bfa1889ebdbff232d567a761ea1ec8d32c18e52.tar.bz2
fetchmail-8bfa1889ebdbff232d567a761ea1ec8d32c18e52.zip
Rename bootstrap.sh to autogen.sh for stability of interfaces.
svn path=/trunk/; revision=3911
Diffstat (limited to 'bootstrap.sh')
-rwxr-xr-xbootstrap.sh37
1 files changed, 0 insertions, 37 deletions
diff --git a/bootstrap.sh b/bootstrap.sh
deleted file mode 100755
index 4202e5ee..00000000
--- a/bootstrap.sh
+++ /dev/null
@@ -1,37 +0,0 @@
-#! /bin/sh
-
-# bootstrap.sh - bootstrap the fetchmail build after a fresh subversion checkout
-# (C) 2004 Matthias Andree -- GNU GPL V2
-
-set -e
-# sanity checks:
-test -f fetchmail.h
-test -f fetchmail.c
-test -f Makefile.am
-rm -rf autom4te.cache
-echo
-echo "Please stand by while generating files,"
-echo "this may take a minute or two..."
-echo
-# Original autogen.sh:
-#rm -f po/Makefile.in.in po/ChangeLog po/ChangeLog~ || true
-#gettextize -c -f || true
-
-# do not use -s here, Eric S. Raymond (ESR) writes they don't
-# work well in Debian's build system
-autoreconf -iv
-
-# Taken from ESR's autgen.sh:
-#
-# For the Debian build, refresh list of +x scripts, to avoid
-# possible breakage if upstream tarball does not include the file
-# or if it is mispackaged for whatever reason
-#
-test -d debian && {
- rm -f debian/executable.files
- find -type f -perm +111 ! -name '.*' -fprint debian/executable.files
-}
-
-echo
-echo "You can now run ./configure and make as usual. See INSTALL for details."
-echo