aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1998-09-08 16:38:58 +0000
committerEric S. Raymond <esr@thyrsus.com>1998-09-08 16:38:58 +0000
commitd4b16eb2e94653b877e60f2c79d79310a84067a9 (patch)
treeb21a7d4b717661a26b8c0cff9299f51bda63bcc3 /Makefile.in
parent53d1265a450e1db28305116bd2fdcff34cbe50d5 (diff)
downloadfetchmail-d4b16eb2e94653b877e60f2c79d79310a84067a9.tar.gz
fetchmail-d4b16eb2e94653b877e60f2c79d79310a84067a9.tar.bz2
fetchmail-d4b16eb2e94653b877e60f2c79d79310a84067a9.zip
No longer needs tar-1.13.
svn path=/trunk/; revision=2070
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index 8d496d9f..51698ec0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -240,10 +240,11 @@ dist: Makefile.in
ls -l fetchmail-$(VERS).tar.gz
@echo "Don't forget to build RPMs from root!"
-# This requires my patch to tar-1.12, or a stock tar-1.13 (not yet released);
-# the version must implement the --name-prefix option.
fetchmail-$(VERS).tar.gz: $(all)
- tar --name-prefix='fetchmail-$(VERS)/' -czf fetchmail-$(VERS).tar.gz `cat MANIFEST`
+ (cd ..; ln -sf fetchmail fetchmail-$(VERS))
+ (cd ..; tar -czf fetchmail-$(VERS).tar.gz `sed <fetchmail-$(VERS)/MANIFEST s:^:fetchmail-$(VERS)/:`)
+ mv ../fetchmail-$(VERS).tar.gz .
+ rm ../fetchmail-$(VERS)
# Make RPMs. You need to be root to make this work
RPMROOT=/usr/src/redhat