aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2000-10-08 14:34:22 +0000
committerEric S. Raymond <esr@thyrsus.com>2000-10-08 14:34:22 +0000
commitc7f3b6621d652480a1b57a6ea2deddd4b71ff2fe (patch)
tree9b7c17d7bf73ffcf937eb9140535622df4c42d29 /Makefile.in
parent288d03eaf77643d32abe2f009029e73955eb786c (diff)
downloadfetchmail-c7f3b6621d652480a1b57a6ea2deddd4b71ff2fe.tar.gz
fetchmail-c7f3b6621d652480a1b57a6ea2deddd4b71ff2fe.tar.bz2
fetchmail-c7f3b6621d652480a1b57a6ea2deddd4b71ff2fe.zip
Before showdots,
svn path=/trunk/; revision=2975
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/Makefile.in b/Makefile.in
index 43100622..e8c05cb6 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -52,6 +52,8 @@ EXTRASRC = @EXTRASRC@
EXTRAOBJ = @EXTRAOBJ@
# EXTRAOBJ = strcasecmp.o getopt.o getopt1.o alloca.o
+DESTDIR =
+
# Common prefix for machine-independent installed files.
prefix = @prefix@
# Common prefix for machine-dependent installed files.
@@ -148,21 +150,21 @@ tags: $(tagsrcs)
.PHONY: install uninstall
install:
@echo "Creating installation directories..."
- $(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(mandir)
+ $(SHELL) ${srcdir}/mkinstalldirs $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)
@echo "Installing fetchmail binary..."
- $(INSTALL_PROGRAM) ./fetchmail $(bindir)/fetchmail
+ $(INSTALL_PROGRAM) ./fetchmail $(DESTDIR)$(bindir)/fetchmail
@echo "Installing fetchmail configurator..."
- $(INSTALL_PROGRAM) ${srcdir}/fetchmailconf $(bindir)/fetchmailconf
+ $(INSTALL_PROGRAM) ${srcdir}/fetchmailconf $(DESTDIR)$(bindir)/fetchmailconf
@echo "Installing manual page..."
- $(INSTALL_DATA) $(srcdir)/fetchmail.man $(mandir)/fetchmail.$(manext)
- rm -f $(mandir)/fetchmailconf.$(manext)
- ln -s $(mandir)/fetchmail.$(manext) $(mandir)/fetchmailconf.$(manext)
+ $(INSTALL_DATA) $(srcdir)/fetchmail.man $(DESTDIR)$(mandir)/fetchmail.$(manext)
+ rm -f $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
+ cd $(DESTDIR)$(mandir) && ln -s fetchmail.$(manext) fetchmailconf.$(manext)
@echo "Installing language catalogs..."
@POMAKE@ install
uninstall:
- rm -f $(bindir)/fetchmail $(bindir)/fetchmailconf
- rm -f $(mandir)/fetchmail.$(manext) $(mandir)/fetchmailconf.$(manext)
+ rm -f $(DESTDIR)$(bindir)/fetchmail $(DESTDIR)$(bindir)/fetchmailconf
+ rm -f $(DESTDIR)$(mandir)/fetchmail.$(manext) $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
@POMAKE@ uninstall
.PHONY: clean realclean distclean mostlyclean