aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1998-05-26 16:25:17 +0000
committerEric S. Raymond <esr@thyrsus.com>1998-05-26 16:25:17 +0000
commit7e5611c7f37f06cad532f27e5fce59fed1fb61ab (patch)
tree5a8656d1344c3b68fb531303531b66c9481571b0 /Makefile.in
parentc794e982836327879fd1e4dc7195dcac2cba44c1 (diff)
downloadfetchmail-7e5611c7f37f06cad532f27e5fce59fed1fb61ab.tar.gz
fetchmail-7e5611c7f37f06cad532f27e5fce59fed1fb61ab.tar.bz2
fetchmail-7e5611c7f37f06cad532f27e5fce59fed1fb61ab.zip
Integrated fetchmailconf.
svn path=/trunk/; revision=1860
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index ab286531..b01f8feb 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -53,8 +53,6 @@ prefix = @prefix@
# Common prefix for machine-dependent installed files.
exec_prefix = @exec_prefix@
-# Name under which to install fetchmail
-instname = fetchmail
# Directory in which to install.
bindir = @bindir@
# Directory to install the Info files in.
@@ -130,21 +128,25 @@ tags: $(tagsrcs)
$(CTAGS) $(tagsrcs)
.PHONY: install installdirs uninstall
-install: installdirs $(bindir)/$(instname) $(mandir)/$(instname).$(manext)
+install: installdirs $(bindir)/fetchmail $(bindir)/fetchmailconf $(mandir)/fetchmail.$(manext)
installdirs:
$(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(mandir)
-$(bindir)/$(instname): fetchmail
- @echo "Installing binary..."
+$(bindir)/fetchmail: fetchmail
+ @echo "Installing fetchmail binary..."
$(INSTALL_PROGRAM) fetchmail $@
-$(mandir)/$(instname).$(manext): fetchmail.man
+$(bindir)/fetchmailconf: fetchmailconf
+ @echo "Installing fetchmail configurator..."
+ $(INSTALL_PROGRAM) fetchmailconf $@
+
+$(mandir)/fetchmail.$(manext): fetchmail.man
@echo "Installing manual page..."
$(INSTALL_DATA) $(srcdir)/fetchmail.man $@
uninstall:
- rm -f $(bindir)/$(instname) $(mandir)/$(instname).$(manext)
+ rm -f $(bindir)/fetchmail $(bindir)/fetchmailconf $(mandir)/fetchmail.$(manext)
.PHONY: clean realclean distclean mostlyclean
clean: