aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-12-25 10:37:09 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-12-25 10:37:09 +0000
commit481f2fe7871aca3171165913d603fc9ce8d12739 (patch)
tree113e6e1442a19763e655729d3160f27df8f575e0 /Makefile.in
parentf098021f7c4b021fde38bc91884e467ac9cde676 (diff)
downloadfetchmail-481f2fe7871aca3171165913d603fc9ce8d12739.tar.gz
fetchmail-481f2fe7871aca3171165913d603fc9ce8d12739.tar.bz2
fetchmail-481f2fe7871aca3171165913d603fc9ce8d12739.zip
Include test code.
svn path=/trunk/; revision=690
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 81b0d76c..d90d907d 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,7 +3,7 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=2.5
+VERS=2.6
PL=0
# Ultrix 2.2 make doesn't expand the value of VPATH.
@@ -153,7 +153,9 @@ fetchmail.spec: $(srcdir)/Makefile.in $(srcdir)/specgen.sh
.PHONY: clean realclean distclean mostlyclean
clean:
-rm -f fetchmail *.o core fetchmail.dvi \
- rcfile_l.c rcfile_y.h rcfile_y.c fetchmail.tar fetchmail.tar.gz
+ rcfile_l.c rcfile_y.h rcfile_y.c \
+ fetchmail.tar fetchmail.tar.gz \
+ linetext[12]
distclean: clean
-rm -f Makefile config.h
@@ -218,6 +220,12 @@ fetchmail-$(VERS).tar: $(all)
fetchmail-$(VERS).tar.gz: fetchmail-$(VERS).tar
gzip -f fetchmail-$(VERS).tar
+# Test for stdio line-buffering lossage on sockets
+linetest1: socket.c
+ $(CC) -g -I. -DMAIN socket.c -o linetest1 # Use setlinebuf
+linetest2: socket.c
+ $(CC) -g -I. -DMAIN -DUSE_STDIO socket.c -o linetest2 # Use setvnbuf
+
# The automatically generated dependencies below may omit config.h
# because it is included with ``#include <config.h>'' rather than
# ``#include "config.h"''. So we add the explicit dependency to make sure.